No Data Available on the chart (Fidelity data)
Author: zanek
Creation Date: 6/25/2009 11:14 PM
profile picture


Does anyone get the "No Data Available" message in the 'Chart' tab from WL (I have 5.3) when trying to backtest after midnight or so ?

I shutdown WL a couple times, but everytime I compile and run a strategy I get that message. In the morning/during the day, everything works fine. I presume they are shutting down their servers ?

Also, I get "No Data Available" even if I compile and run any of the examples that come with WL 5.3, so that eliminates it just being my code.

I'm able to login to Fidelity from within WL also.
profile picture


Have you tried turning On Demand Update in Data Manager off?

(For what Fidelity does to their data servers, please ask them directly.)
profile picture


In my experience, this message usually appears when you have a chart set up for streaming but, you're requesting a chart from Yahoo! or another data provider that does not support streaming charts.

Make sure:
1. that you're clicking symbols in a Fidelity DataSet, or,
2. turn off Streaming
profile picture


I am having trouble getting Fidelity intraday data for certain index symbols and timeframes. I followed the suggestions in this post and deleted all relevant .xxxxsymbol.wl files in relevant n minutes folder. It helped but not completely. I then deleted all n minute folders and got some different results. For some symbols I can get 1 year of intraday data, but not 2 years. I get a Data Not Available message when I open the Chart window on a symbol.

I seem to be having more trouble with the lower minute bars, particularly 1 minute, but it varies by symbol and does not seem to be consistent.

What to try next?

When I deleted the .WL file and n minute folders, they don't seem to be recreated by WL. Is that a problem?

Note: I have a folder as the parent of the Data folder.
profile picture


I am having trouble getting intraday data for certain index symbols and timeframes.

What trouble exactly? Like this: Open Issues > Fidelity data can not be updated except for X minute? If so, please follow workaround suggestions.

I get a Data Not Available message when I open the Chart window on a symbol.

This must be caused by not having updated the data.

When I deleted the .WL file and n minute folders, they don't seem to be recreated by WL. Is that a problem?

Of course not. When on demand update is unchecked (and you've deleted the data), either a manual or scheduled update brings back the .WL files.
profile picture


What trouble exactly? Like this: Open Issues > Fidelity data can not be updated except for X minute? If so, please follow workaround suggestions.

Not sure that describes it.

Specific behavior on .RUT:
- I can view 3 min bars for 10 years
- I can view1 min bars for 1 year
- When I try to view 2 years of 1 min data I get a No Data Available message
- When I reload chart data it gives a message it completed successfully, but I only have several one 1 min bars for today data that were loaded with streaming since opening chart window, even though data selection is 2 years
- If I reselect .RUT and timeframe of 2 years, I get still No Data Available message
- When I update Fidelity data I get the following in log

Please log in to see this code.

- Still same problem as above

I deleted files in 1 min folder before executing above tasks

My 1 min folder is still empty after above actions; there is no file %2ERUT.WL in 1 min folder, as there is 3 and 5 min folder.

Finally, I deleted symbol from all Dataset, and created new Dataset and added 1 min Fidelity data. Same problem. Still no .WL file (or any files) in 1 min folder. Is that the cause of the problem?
profile picture


I can't explain why it happened, but when I closed and reopened chart window, 2 year 1 min bars started working. .WL file now appears in 1 min folder. I'm not sure what I did that made it work. Closing and opening chart window after the steps above?
profile picture


Nice to know it has helped. Since you're the only one with .RUT data issues (Alerts for Intraday strategy on .RUT (Fidelity index symbol) are not generated), there may be a conflict when you're trying to update the same symbol from multiple tools.

A suggestion here may be to avoid reloading the data while streaming it in a chart and/or Strategy Monitor or with on demand update turned on. Ideally:

1. Disable on demand data update
2. Turn SM off
3. Turn streaming charts off
4. Double check that the "1 minute" subfolder under AppData\...\FidelityStaticProvider is completely deleted
5. Reload the .RUT data (maybe even outside market hours)
profile picture


Now that I have 1 min data I am working the same problem with 10 min data. I can't figure out how to replicate whatever I did to get 1 min working.

I followed all of your above steps (except after-hours download) but I can't get even 1 month or 10 minute bars in clean chart window. No 10 minute folder recreated, hence no .WL file in a folder that doesn't exist.

I have tried both Reload Chart History and using Data Manager update. On the Data Sets tab it lists a column for scale. Hadn't noticed it before, but is each Dataset limited to one scale?
profile picture


OK. I think I may have amagic procedure, but it raises new questions.

I deleted the non-working n minute folders as you suggested. This time (and I now recall, last time), I created a new Dataset, selected the timeframe (first one was 10 minutes) added the symbol .RUT, named the Dataset, and clicked Finish.

When I opened a Chart Window on the symbol in the new Dataset, I got the typical No Data Available message. I clicked Reload Chart Data.

When it completed, correct data for that Scale and Data Range Selected appeared.

I followed this process for 15, and 30 minute, creating a new Dataset for the specific Scale each time and it worked reliably. Each time I confirmed that there was a re-created folder in AppData\...\FidelityStaticProvider for that n minute, and the folder contained a .%2ERUT.WL file.

Now for the weirdness:

1. When I tried this technique with 60 min data, I noticed the dropdown in the Create Dataset dialog maxes out at 30 minutes. No 60 minutes. (Why is that?). However, I was able to load 60 minute data in a chart. There is no 60 minute folder in AppData\...\FidelityStaticProvider , and of course no .WL specifically for 60 min data. Where is that data stored?

2. Once I got all the minute data working, I deleted the ad hoc Datasets I had just created. All time Scales still work from a single Symbol in a random Dataset. It would appear that the procedure I used was necessary (although possibly not exclusive) to recreate some files and folders.

I'm still confused about why the Data Manager tags Datasets with a timeframe. And where is the 60 minute data on my computer stored?

Does all of this make sense to you?
profile picture


In the Data Manager, you haven't activated "Also Update Symbols that you accessed, but are not contained in DataSets". (In other words, "Update only Symbols that are contained in DataSets" is active). This perfectly explains not getting the data and subsequent success after adding .RUT to a DataSet.

As for 60-min data, Cone will correct me if I'm wrong but this may be caused by building Hourly data from 30-minute by the Fidelity static provider. There were no native 60-min bars which were built on-the-fly but cached in the "30 minute" subfolder. At least this was true long ago in v5.x times. Things might have changed since then.
profile picture


After trying all of the above, still unable to get a 1 minute chart for VTI.

1. Turned off Update Data On Demand in File Tab
2. Deleted VTI in 1 Minute folder
3. Created new Data set.
4. Used Data Manager to Update new Data set
5. 1 Minute data was created.
6. No Data Available on chart.

(Not Streaming, nor Monitoring Strategy)

Please advise.
profile picture


Thanks to your detailed report, it's clear that you do have the data so the issue here is different (a cosmetic one). Try to choose a bigger data range i.e. always more than 1 day.
profile picture


Thanks Eugene.

It works with 3 days, 1 minute...but shows only 1 day in the chart...

4 days, 1 minute...shows 2 days in the chart.

Not what one would expect,
and 2 days, 1 minute..."No Data available"

It looks as though for 1 minute charts, 3 days is the minimum range.

Thanks again,
profile picture


That's because it's still weekend I guess. As you can see in the WL User Guide > Reference > Data Panel > Data Range Control, "Most Recent" loads data for the most-recent calendar period (i.e. days). Subtracting Saturday and Sunday explains it.

This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).