- ago
Greetings,
I don't know if this is for Wealth Lab or Finantic. I am attempting to get a 4 strategy meta strategy into shape for trading. I set each of the 4 strategies to "Advanced Pos Sizer" then selected "Max Risk % Limited to % of equity". This was the result:

Only the second strategy lists the correct position sizer. The other three are stuck on "Max % Risk". However, if I then select the "Max % Risk", I see this:

Wealth Lab appears to be confused. The 3 strategies set to "Max Risk %" do Position Size to Max Risk %, while the one correctly sizes for 2%risk/10% equity. Any help appreciated.
-sifty
0
786
11 Replies

Reply

Bookmark

Sort
- ago
#1
It looks like the PosSizers are indeed may be being confused because their names start from the same "Max Risk...", we need to investigate.
0
- ago
#2
Thank you Eugene!
0
- ago
#3
Think I have an idea of what's going on here. First, I cannot reproduce name confusion. What I can do though is failure to apply Advanced PosSizer's settings when its dialog is OKed at first. When you reopen the dialog and click OK again it will work - that's the workaround for now.
0
- ago
#4
Thank you Eugene. I guess next time I will keep clicking buttons rather than just stop ;-)
-sifty
0
- ago
#7
You're welcome. We should get this bug fixed in B37 (it may be too late for B36).
0
pmbf8
- ago
#8
Hi sifty,

Can I ask how did you setup "Max Risk % Limited to % of Equity" PosSizer?

I am using WL 8 Build 37 and I don't see "Max Risk % Limited to % of Equity" under the category, Advanced Pos Sizer.

Please refer to the below screenshot for my current available options.



pmbf
0
- ago
#9
Hi,

It's part of the 3rd party extension finantic.Indicators:
https://www.wealth-lab.com/extension/detail/finantic.Indicators#changeLog
0
- ago
#10
@sifty

Just verified Dion's fix of the bug, please look forward to it in B40:

QUOTE:
What I can do though is failure to apply Advanced PosSizer's settings when its dialog is OKed at first. When you reopen the dialog and click OK again it will work - that's the workaround for now.
0
- ago
#11
Thank you for the heads up Eugene. Looking forward to B40.
0

Reply

Bookmark

Sort