- ago
Hi. Is there something wrong with the calculation?
According to the screenshots, I would expect the quantity multiplied by the entry price to be 3000.





Because of that, I also switched to the percentage calculation and checked the first trades.
The settings I have chosen so that 10% (3000, -) per trade should be used. Again, it does not seem to fit.



Sorry if i miss sth. obvious and thanks for a short feedback.
0
186
Solved
9 Answers

Reply

Bookmark

Sort
Cone7
- ago
#1
Preferences > Backtest Settings > Other Settings
Convert Trade Quantities to Round Lots - is checked. Uncheck it.
0
MIH7
- ago
#2
No, it is not checked.




0
Cone7
- ago
#3
Is the strategy assigning a value to a Transaction.Quantity? It may be (must be) doing this after exiting a Position to exit a partial number of shares. When you do that, the original $3000 position is split into 2 positions. It would be easy to see that if you sorted the list by Entry Date and then by Symbol.
0
MIH7
- ago
#4
Hello Cone. I think the calculations are correct (summed up) and i was confused by to many signals in the 1 minute time frame and the 15 minute time frame.

15 Minute


1 Minute


What confuses me in the 1 minute time frame is, that the sum is about 30k. But there are more than 10 open positions. There are some symbols only using a fraction of 3K.

Ok, I think i can limit it with the backtest preferences "Max Open Pos". Then i would expect "10" open positions with about 3K. Out of curiosity, i think it is intended, but why does the backtester use a fraction if there is enough cash to make a "full" position?

Of course i am happy that it isn't a bug. How can i avoid to open positions with rest amounts like 124,2 or 266,0? I would like to have some kind of threshold for the minimum position size. When scalping, theses positions are too costly with respect to commissions.
0
Cone7
- ago
#5
I just reviewed your settings again... you're using a 10% Volume limit. So if only $10K is traded on a bar, your trade will be limited to $1K.

For example, take 15-min bar TH trade on 16.05.22 at 11:00. Only 200 shares traded on that bar with a closing price of 5.88. That's only about $1200, and 10% of 200 is 20 shares - your size.
1
Best Answer
MIH7
- ago
#6
What settings are you talking of? Sorry, i am not able to follow you now. Here is the setting i use for the latest results.



What i can follow is, that when 29833$ (as example) are assigned, a position might be opened with less than 3K, for example 167$. (as mentioned i would like to avoid such a case)
But if i have about 3800$ free to assign, why are there positions with 485$ for example ? You can look at BALY in the list of the 1 minute results.
0
- ago
#7
This is the setting that is limiting your share sizes:

1
MIH7
- ago
#8
Thank you Cone, thank you Glitch. That's the point. I simply did not realized that feature and was not aware of what it is doing.
0
Cone7
- ago
#9
Although it's not enabled, you also have 10% Slippage configured. If you're going to enable it, it should be set to something more on the order of 0.1%, or even 0.01%.

Tip:
You can read about what each of these settings does, just by hitting F1. This works for any Wealth-Lab tool or Preference dialog you have in focus.
1

Reply

Bookmark

Sort