- ago
Just noticed this today:



Not running any strategy optimizations or any active strategies. Streaming is not running right now, however status bar says "Alpaca: Streaming Disconnected: An exception occurred while executing. How can I stop streaming if I am not running any strategies now?
0
739
Solved
11 Replies

Reply

Bookmark

Sort
Glitch8
 ( 10.99% )
- ago
#1
The latent CPU load is nothing to worry about, most likely just WPF rendering things. The status bar message obviously refers to a point in the past where you WERE streaming. You should even see the Timestamp it was generated if you click on it. Are you say you didn't do any streaming at all during the session?
0
- ago
#2
I opened Strategy monitor yesterday and loaded the strategy there selecting "Use Streaming data" and activated the strategy, but since then I've changed strategy to use polling, then deactivated the strategy.

I've noticed that when I reopen a new empty WL7 instance it does not do streaming, but the moment I open a chart or load a saved strategy, it connects to Alpaca streaming provider, even if Streaming is not enabled on the chart. How can I forcefully disable streaming for a chart/strategy?
0
Glitch8
 ( 10.99% )
- ago
#3
Alpaca provides not only streaming, but also historical data and broker connection. In all these cases it has to connect. So, maybe you have Alpaca selected as the default broker? Or you're using intraday data? Then you'll see Alpaca get connected.
0
- ago
#4
Btw, I am not even using Alpaca for DataSets in Strategy and I don't even have any Alpaca DataSets defined in Data Manager, so I am not sure how it gets picked up.
0
- ago
#5
Not using intraday data.
Where can I see/change default broker?
0
Glitch8
 ( 10.99% )
- ago
#6
The Order Manager

0
- ago
#7
I've noticed that even if I enable "Offline Mode" in File menu and then open a chart, it still connects to Alpaca, so I wonder what is the setting that makes it do work this way
1
- ago
#8
Okay, I went to Order manager and switched to TD and I have "Streaming Quote" not enabled, but when I open a chart, WL7 connects to TD right away, even though Streaming is not enabled and "Offline Mode" is selected.

Is there a way to fully prevent WL from connecting to steaming provider?
0
Glitch8
 ( 10.99% )
- ago
#9
Once again, it's not connecting specifically to the streaming provider. Like Alpaca, TD is also a provider of not only streaming, but also historical data and broker. If you select TD as your default broker, it will attempt to connect to TD when you open a chart. It does this so that your account list can be prepared in the Signals tab and ready to place or stage any generated Signals.

If you want to avoid any kind of connection, simply select Dummy Broker as the default broker.
0
Best Answer
- ago
#10
Thank you - it seems that using Dummy Broker + Offline mode is preventing WL from connecting to Streaming providers.

I still have a question of CPU utilization. Here are my observations:
1. WL7 loaded with no windows open: ~0% CPU
2. Strategy Loaded: ~0% CPU
3. After backtest executed (offline mode, so only connected to dummy broker): ~10-15% continuously, including some GPU utilization
4. Strategy closed: back to ~0% CPU.

It seems that something is repeatedly running once backtest is is completed - any idea what it could be?
0
Glitch8
 ( 10.99% )
- ago
#11
It could be the latent WPF framework, there are a few animations like the Signals flashing, etc, that WPF consumes some CPU over. Nothing to really be concerned over.
0

Reply

Bookmark

Sort