- ago
As already mentioned in another topic (https://www.wealth-lab.com/Discussion/Optimization-and-backtests-slowdown-in-B32-9314 Topic 18) I have delays when running backtests due to the extension finantic.ScoreCard.

When I restart WL8 and run a backtest, this delay lasts up to 10 seconds. Symbols are loaded, but things don’t go any further. The wheel spins and nothing happens! The more days WL8 is active the bigger this delay process becomes and can last up to 20 seconds. Over time, this behavior becomes really unacceptable, so I disabled the extension until it's solved.

Here's an overview of my basic configuration and the favorite metrics I have used with the Extension:

0
424
Solved
2 Replies

Reply

Bookmark

Sort
- ago
#1
Do you see these delays at the start of backtest, right after data loading, or at the end of backtest?

(finantic.ScoreCard becomes active - and uses CPU - only at the end of backtest, when all stats are collected)

What Performance Visualizers are active?

The Performance Metrics from finantic.ScorCard are designed to be fast. Only the metrics which are displayed are calculated. This should not take longer than one second.

But then there is Compare tool:


This one is designed to allow all sorts of comparisons from older backtests. It calculates all available performance metrics. If you have a big backtest (many positions) this may take some time.

If you don't use/need Compare Tool just disable it in Preferences->Backtest->Performance Visualizers.
1
Best Answer
- ago
#2
The delay comes at the end of the backtest.

You are right, as soon as I inactivate the comparer (under Preferences -> Backtests), this delay is gone.
1

Reply

Bookmark

Sort