- ago
WL8 keeps giving me this error
Could not find any discussion related to this problem. Any comments? Thanks!
0
221
8 Replies

Reply

Bookmark

Sort
- ago
#1
I notice you're running WL8 B16; for the record, which build of Alpaca extension is installed?
0
Cone7
 ( 43.16% )
- ago
#2
Hint: upgrade Alpaca to Build 6
0
- ago
#3
I am using Alpaca build 6 with WL8 build 16. Had the same issue for Alpaca build 5 with WL8 build 15. I've also tried a fresh WL8 build 16 (and Alpaca B6) installation.
0
Cone7
 ( 43.16% )
- ago
#4
Let's start at the beginning.

1. Restart Wealth-Lab
2. Open the Orders Manager
3. Select Alpaca > Connect

What's the result? Right click in the Message area and Copy all Message Details to Clipboard and paste them here.

Example: My result (no errors) -
CODE:
9/13/2022 04:28:05:157 Alpaca Connected -------- 9/13/2022 04:28:05:160 Alpaca Alpaca Broker: Connected to Alpaca Broker: Timestamp: 9/13/2022 4:28:02 AM, NextOpen: 9/13/2022 9:30:00 AM, NextClose: 9/13/2022 4:00:00 PM --------
0
Cone7
 ( 43.16% )
- ago
#5
Really the errors indicate an incompatible configuration. Please also check again that it says build 6 here on Tools > Home Page

0
- ago
#6
Thank you for the answers. I've restarted WL8. Unfortunately, I cannot see Alpaca as an option under Order Manager. It also does not show up under historical providers. Here is a screenshot summary:

0
- ago
#7
Hello again. A quick update:

I've uninstalled WL8, deleted the folder under Program Files, and deleted the AppData\Roaming\WealthLab8 folder as well. Did a fresh installation and it finally worked. I am not sure what the issue was but it seems resolved now...
0
- ago
#8
QUOTE:
and deleted the AppData\Roaming\WealthLab8 folder as well

Glad to see you're up and running again. Probably it's the config file which was the source of error (which means we may need to be more defensive when initializing the Alpaca provider).
0

Reply

Bookmark

Sort