- ago
There is a display problem when using IndOnInd SMA on volume :




I saw that now we can add and draw on the backtest chart, but we cannot change the block indicators and the time unit. Why is this problematic? (If we consider “chart” different from “backtest results”)
0
385
Solved
6 Replies

Reply

Bookmark

Sort
- ago
#1
Here's a workaround. Click "Open as C# Coded Strategy" and change the indicator plotting code as follows:

CODE:
//PlotIndicator(indicator2,new WLColor(0,0,0)); PlotIndicator(indicator2,new WLColor(0,0,0),default,default,"Volume");
0
- ago
#2
And what to do in this case? and if I use several time units on the volume indicator, how can I duplicate it?
Also this will be useful to me, what line of code to make an indicator disappear on the chart?
In this example the data scale is 1h
0
Cone8
 ( 23.56% )
- ago
#3
Currently, those plots aren't "Volume pane" friendly. The only option is to click "Open as C# Coded Strategy" and:

1. Remove the PlotIndicator statements. Just put 2 backslashes in front like this -
CODE:
//PlotIndicator(indicator2,new WLColor(0,0,0));


OR,
2. Specify the volume pane for the indicators that use Volume, like Eugene showed above, or like this -
CODE:
//WAS: //PlotIndicator(indicator2,new WLColor(0,0,0)); //CHANGE TO: PlotIndicator(indicator2,new WLColor(0,0,0), paneTag: "Volume");


You'll need to do that in 2 places.
0
Glitch8
 ( 13.75% )
- ago
#4
For the first condition you don't need to use IndOnInd. Just use a normal Indicator Compare to Indicator and select Volume > SMA and change the SMA parameter from Close to Volume.
1
Glitch8
 ( 13.75% )
- ago
#5
But I'm fixing these for Build 49 so they will plot correctly in the Volume pane.
0
Best Answer

Reply

Bookmark

Sort