a Quirk with Limit Orders
Author: topcat77
Creation Date: 10/16/2008 10:44 AM
profile picture

topcat77

#1

My 1-min bar program autotrades through Fidelity's ATP platform. On a choppy day like yesterday there were a number of instances when the last trade price for a security was already higher than the limit price that WL placed. This generated a query message " please review your order" and simultaneously an error meggage for the bracketed stop order. The net result was that WL stopped placing orders at subsequent bars.

I have spoken to Fidelity but they don't have a "fix" that can turn off the "review" message.

Is there a way to get WL to autoplace a "market" order when a limit is reached? (which, of cource, is a subtle difference from a limit order?)

The alternative is to not use limit orders to exit

profile picture

Cone

#2
Thanks for this. The message and the error are generated from Fidelity's back end subsystem, but it certainly seems reasonable for Fidelity to place the order without questioning it since the trading result would be a better price anyway. Making WLP transform the error into a market order could work too, but that solution seems sub-optimal.

Could you please create a Support Ticket so that I have it in my queue to follow up.