Meaning of Different Font Colors in Strategy Monitor
Author: jeffjs2003
Creation Date: 2/1/2018 4:07 PM
profile picture

jeffjs2003

#1
I am running 12 different strategies in Strategy Monitor. The strategies seem to be working properly in that I'm getting real-time alerts for each of them. They all cycle through to the end, each displaying "Leaving Filter Monitor Thread" ready for the next iteration, as they should,

The font color for each row is blue in 8 of the strategies and black for 4 of them. (They all go to red when active.) Does anybody know what black/blue font color is supposed to signify, if anything? As I said, the strategies seem to be running properly so I'm not overly concerned about it, but I'd like to know if it's a flag of some sort that I should be aware of.
profile picture

Eugene

#2
Black is inactive (normal), it turns blue when "Time's up!", and red when it runs. The blue color means that no new data were retrieved (no updates for up to 50 seconds after the completion of a 1 minute bar).
profile picture

jeffjs2003

#3
Note: I'm using 30 minute bars.

1. Immediately after each run the red reverts to the either the black or the blue and remains that color until the next run 30 minutes later.

2. The same strategies/datasets consistantly go to the same black/blue irrespective of which ones generated alerts. In other words, the same 4 strategies/datasets immediatly go to black (after red) and the same 8 strategies/datasets always go to blue (after red).

3. Immediately prior to execution the 4 black rows remain black until it turns red, i.e., they don't go to blue before the run (red). This ocuurrs regardless of whether alerts were generated or not.

4. The 8 blue rows remain blue (except when red during runs) even though alerts were generated in these rows.

Based on your response it sounds like item 3 above shouldn't occur since I should be seeing the black go to blue just prior to the run? Also, shouldn't item 4 above go to black since alerts were generated?
profile picture

Eugene

#4
It all would start making sense if we knew the details i.e. at least the DataSet / symbols, bar scale, data loading range, and probably some item logs. But before anything else please go through Cone's advices in this thread that should look familiar:

Many "symbols left"
profile picture

jeffjs2003

#5
1. I've gone through the thread as you suggested. It's been a while, but as I recall the "Many Symbols left" problem was resolved when I switched from 60 min bars to 30 min bars and eliminated the symbols that contained forward slashes. (I've subsequently determined that these type of symbols can still work if the forward slashes are removed.)

2. See attached DataSet/symbols

3. Bar scale: 30 minute

4. Data Loading range: 23 Days

5. See attached log files for black and blue font color strategy runs. As previously described, these colors didn't change before and after after the runs except when they ran, in which case they went to red.
profile picture

Eugene

#6
One of the symbols in the "blue" DataSet is invalid: SCSS. It's recommended to exclude such symbols from SM operation. However, I don't see it in the logs - maybe Symbol Quarantine is engaged? The logs look OK on the surface, no issue detected.
profile picture

jeffjs2003

#7
Yes, that was the problem. I deleted that symbol from the DataSet and the font color went from blue to black. I checked the other DataSets with Symbol Details (which I didn't know about before) in the Data Manager and found other invalid symbols and deleted those as well. This changed the font color of other remaining "blue" strategies to black and all run ok. As far as the Symbol Quarantine is concerned: yes, I do have "Turn on Symbol management" enabled which I assume you were referring to. What is your recommendation as far as having that enabled? Thanks for your help!