Index-Lab: Invalid indicator settings error
Author: richard1000
Creation Date: 12/12/2013 11:54 AM
profile picture

richard1000

#1
I'm getting the following error: "Error: Invalid indicator settings. Unable to get Data for index: %STOCHD_DOW_30"

Steps to reproduce the error.
1) Within Index-lab's Index Builder, choose Aggregate Indicator.
2) Choose Dow 30 DataSet.
3) Choose StochD with default settings.
4) Choose Daily scale and All Data range.
5) Update and the error appears
profile picture

Eugene

#2
Although it's not the first time I hear about this error, I'm not successful at reproducing it following the steps above (using Yahoo! data). Please help me collect more evidence:

1. Let's determine what went wrong with its settings. After turning on hidden file/folder visibility (Windows Control Panel > Folder Options), please navigate here:

c:\Users\Windows username\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\

Zip and attach the following subfolders: CustomIndices and DataSets.

2. If you truncate the index file's data using the Data Tool or delete the file itself ( ..\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\IndexStaticProvider\Daily\..) and then update, does that make the error disappear?

Thanks.
profile picture

richard1000

#3
I am using Fidelity data. I haven't tried Yahoo data yet.

1) I have attached the zip files.

2) Same result after I deleted the file and then updated again.
profile picture

richard1000

#4
Please delete the previous attachment. It's got too much junk in it. I've attached a cleaner file.
profile picture

Eugene

#5
Thanks. Still no success with your files. Investigating further.

I'll try to remember to delete the first attachment later, but at the moment we might still need it for our troubleshooting.
profile picture

richard1000

#6
I tried it with Yahoo data and the result is the same error. When I tried other Index-Lab definitions created by Aggregate Indicator, Above Indicator's Value and Below Indicator's Value, it is also not working. eg. aggregate RSI, above RSI value 65, below RSI value 35.

Other definitions such as Above 200 SMA, Advance Decline Line, etc ... are working but I haven't tested all the definitions.
profile picture

Eugene

#7
Fine, so this issue doesn't seem limited to the downloaded Fidelity data. Chances are there might be some sort of conflict with outdated extension. Now, here's one more procedure to try using the Extension Manager (assuming that all these extensions are installed and are NOT up to date):

1. Update TASCIndicators. Restart WLP. Retry your steps above. Does if the error persist?

2. Update Community Indicators. Restart WLP. Retry your steps above. Does if the error persist?

3. Update MS123 IndexDefinitions. Restart WLP. Retry your steps above. Note if the error persists?

If some extension is not installed e.g. MS123 IndexDefinitions, no need to install/update that -- just indicate it here. And it's important to NOT update all three in one shot - I'm trying to zero in on the potential culprit. Thanks in advance.
profile picture

richard1000

#8
These extensions are all updated. However, just to be certain, I reinstalled each extension one at a time as suggested above. The error still appeared and did not make any difference.
profile picture

Eugene

#9
Thanks for the information. That's a tough one, and I have a confirmation from the developers that no change to IL was recorded in 6.6.

1. Are you doing something else in WLP when getting the error - like performing an on demand data update request, streaming a chart of an Index?

2. Does every already existing Index (created before) open up normally w/o throwing this error?

3. With WLP closed, back up your...

a) CustomIndices and IndexStaticProvider folders folder by completely moving them outside,
b) Index-Lab DataSets from the DataSets folder by moving them outside

...Restart WLP and retry your walkthrough from post #1. Can you reproduce the error now?
profile picture

LenMoz

#10
For what it's worth, in September I created an index (it worked then, but I never really used it). In response to this thread, I tried it today and also got Richard1000's error, "Error: Invalid indicator settings. Unable to get Data for index: %LJMINDEX". Just trying to help rule out that it's specific to Richard1000.
profile picture

Eugene

#11
Thanks Leonard. It's not specific to richard1000, I already knew that.

1. What your %LJMINDEX is? Could you please zip and attach its XML file from C:\Users\you\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\CustomIndices\ ?
2. Have you installed and/or used MS123 IndexDefinitions? Which version is it?
profile picture

richard1000

#12
1) Data on Demand and Streaming are turned off when updating.

2) Every previous existing index opens and updates fine.

The problem ones are Aggregate Indicator, Above Indicator's Value and Below Indicator's Value. To update these indices, Index-Lab needs to communicate with Technical Indicators (e.g. RSI, Stochastics, etc) but currently, it does not and/or indicator variables are misplaced.

3) After moving CustomIndices, IndexStaticProvider and Index-Lab DataSets to outside, and restart the WLP, the error still exists.
profile picture

LenMoz

#13
Responding to Eugene at #11

QUOTE:
1. What your %LJMINDEX is? Could you please zip and attach its XML file from C:\Users\you\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\CustomIndices\ ?


Attached as plain text (I modified its suffix from .xml to .txt. to make an uploadable type). Also, now using its real name, %LJMNN001_TRIN_SMALLTECH.XML. I didn't think the name mattered in my #10 post.

QUOTE:
2. Have you installed and/or used MS123 IndexDefinitions? Which version is it?

Not installed.
profile picture

Eugene

#14
Thank you both. We'll continue our investigation using the evidence you provided.

Richard:

Yes I see that the common ground is that these indexes all accept an indicator as a parameter, but the thing is, those parameters in both your or LenMoz's XML files are correct.

Leonard:

And your %LJMNN... index is the same Aggregate Indicator that richard1000 is having trouble with. Are you also NOT able to create an Aggregate Indicator from scratch using e.g. StochD?
profile picture

LenMoz

#15
I can create Aggregate StochD successfully, but when I run data manager to populate custom indices, I get errors for both...
===============================================================================================
Requesting updates for %LJMNN001_TRIN_SMALLTECH
%LJMNN001_TRIN_SMALLTECH Error Processing: %LJMNN001_TRIN_SMALLTECH
%STOCHD_DOW_30 Error: Error: Invalid indicator settings.

Provider update complete for Custom Indexes
----------------

Update completed (19.981 sec)
----------------
===============================================================================================
I used the default STOCHD settings when creating the custom index.
profile picture

Eugene

#16
Noted, thanks. The developers have been notified.
profile picture

Eugene

#17
Added to Open Issues.
profile picture

richard1000

#18
Just a quick feedback.
Wealth-Lab 6.7 fixed the Aggregate Indicator but the Above/Below Indicator Value still has not been fixed. So this issue should be still open.
profile picture

Cone

#19
First, a little history...
Nothing was required to be changed in the code base to fix the earlier issue with the Index-Lab Aggregate Indicator. It turned out to be an [apparent] Microsoft bug that requires you to uncheck and recheck the "Build" box in Visual Studio's Configuration Manager. Imagine that!

With that said, I need some context for this [new?] problem "Above/Below Indicator Value". This is not an Index Definition in Index-Lab (afaik).
profile picture

richard1000

#20
Try the following to recreate the problem.

1. Open Index-Lab and under Index Builder tab, choose the Index Definition "Above Indicator's Value" (should be listed below "Tsokakis MACDBull").

2. Choose "Dow 30" for DataSet.

3. Select RSI for indicator with default settings and Indicator value of 65.

4. Give it a name.

5. Try to update and it will fail with a message "Error: Invalid indicator settings."

Likewise, the Index Definition "Below Indicator's Value" gives same result.
profile picture

Eugene

#21
QUOTE:
5. Try to update and it will fail with a message "Error: Invalid indicator settings."

Just to add: it will fail only in Wealth-Lab Pro 6.7 -- in Developer 6.6 it works OK.
profile picture

Eugene

#22
I'll look into the "Above/Below Indicator" problem right after getting WLD 6.8 for pre-release testing.
profile picture

robinkno

#23
Hi Eugene

I am still getting this error: "Error: Invalid indicator settings", using the std dev above/below Indicator and have WLD 6.9 installed. Any update?

Thanks
Robin.

profile picture

Eugene

#24
Hi Robin,

I don't think you have WLD installed - rather WLP and this makes all the difference. The bug was partially fixed in WL 6.8 for the Aggregate Indicator according to the Wiki but not so for the Above/Below Indicator. I can update it in WLD 6.9 without a hitch but WLP should still be affected. I'll raise this once again, hoping that this might be considered by Fidelity in some future release.
profile picture

robinkno

#25
Yes, WLP not WLD.
I would really appreciate getting this fixed in WLP.
profile picture

Eugene

#26
In a duplicate thread, Harapa asked:

QUOTE:
Data Set:NASDAQ100 (Daily)
Indicator Settings:Default (SMA20, STD DEV 2, STD DEV Period 20)

Returns:
"Error:Invalid Indicator Settings"
Unable to get data for index..."

What is it I am doing wrong?
profile picture

Eugene

#27
Harapa, please read this forum thread and you should know.
profile picture

Harapa

#28
I have been though this before. Looks like a low priority fix!