Error in Visualizer: TabPage: "Equity Curve", Removing
Author: hplein
Creation Date: 9/17/2020 1:16 AM
profile picture


Using the strategy as provided get an error and all the quantities are set to 1.

It references a variable index which I do not see. Please help.
profile picture


Firstly, "QQQQ Crash Strategy Error" is a suboptimal problem description so I'm renaming the topic's title. The Strategy has little to do with this. "Error in Visualizer: TabPage: "Equity Curve", Removing" summarizes the gist of the problem much better. Now if one searches for "removing" he'd find these hits:

Error in Visualizer Trades, Removing
Error in Visualizer: TabPage: {MAE/MFE}, removing
Error in Visualizer: TabPage: {Performance+}, removing

Furthermore, an error message encountered is msost likely documented in one of the pages of our Knowledge Base (the Wiki):

1. Known Errors
2. Open Issues

In particular, Errors | Extensions, Other errors > Visualizer could not be loaded should provide you with food for thought. This error is about data. If you cannot fix the data on your own and need further assitance with this problem, please provide enough facts about the data and its loading settings.
profile picture


The data set used is the S&P 400 Mid cap. (see attached).

Please would you help fix the data.
profile picture


Sure. The Data Tool extension has a "Data checker" feature which helps detect data anomalies. Install it and restart WLD.

Check out its online user guide. In your case, start with all options unchecked to examine the data for errors which affect performance visualizers the most: erronenous bars, zero bars, duplicate dates and out of sequence dates. When it finishes, there should be a popup dialog with report of found issues.
profile picture


Ran the data checker and the data cleaner for all check boxes. Then tried the strategy again and got the same error: (see attached)

The debug and error window has the message:

Error processing symbol XLNX Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

Which happens to be the last symbol in the dataset. Tried deleting the symbol and got a similar message with its symbol in the debug and error window. Just to be sure I repeated the process with the next last symbol and the same result.

What do you recommend I do? The datasets were recently created so I doubt deleting and recreating I suspect will not result in anything different.
profile picture


Ran the data checker and the data cleaner for all check boxes.

So what does the report show (for all the options unchecked?)

Tried deleting the symbol and got a similar message with its symbol in the debug and error window.

No, this is not going to work. That's how the debug log is known to work and it's not very helpful.

What do you recommend I do?

Let's get rid of all obvious errors. Try switching to "Data cleaner", check all boxes and click "Clean data". If that won't fix it, rerun the data checker to find out if there are misaligned bars (duplicate and out of sequence dates).
profile picture


Ran the clean Data with all the boxes checked on all my datasets. When I try to run the Data Checker I get the error window (see attached)
and when I click Details I get the message in the attached. I then select the continue and get:

PCAR Out of sequence date 20170512
SGEN Out of sequence date 20200901

I get similar Out of sequence date for all but one of my datasets.

When I the try and run the strategy I get The Visualizer Error as before and the alert quantities a are all 1.
profile picture


with all the boxes checked

🤦Told twice to uncheck them... 😊 Anyway, restart the Data Manager to get rid of the exception. If it doesn't work, restart WLD.

OK forget about the Data Tool. Just ran your code attached to post #1 on DataSet from post #3 using freshly downloaded Yahoo data, under various data loading ranges. Cannot reproduce no visualizer error.

My suggestion is to perform a bulk reload of the data:

1. Highlight the DataSet in the Data Manager
2. Click "Symbol Details" (!)
3. Select all symbols - for example, click on the top one and then strike Shift-End to select all the 400
4. Right click and choose "Reload symbol data file"
5. Update the DataSet

If followed precisely, this procedure will first wipe out and then reload the *.WL data files for your DataSet. (Deleting the DataSet and recreating it is absolutely useless in this sense.) Make sure the data update log is error free (except some Error 404 which is OK - the non-existing symbols could then be removed using the Data Tool). Once done, your data should be fine to run the script w/o errors.
profile picture


Thank you now I am not getting errors when I Run the strategies. However when I look at the update log there are several 404 errors yest they are valid symbols. I have attached the log. The data is all being requested from Yahoo.
profile picture


Glad to see you're up and running again!

Re: 404. There are just way too many of them. Please look for suggestions in these topics:

Yahoo provider Error 404 on symbol
Yahoo errors 422 (unprocessable entity), 404 (not found)

If you still have some follow-up, feel free to ask in these topics. However, actually hardly something could be improved on our end.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).