Max Percent Risk for Forex
Author: chinwaihoong
Creation Date: 7/4/2016 8:50 AM
profile picture

chinwaihoong

#1
Im a new user so forgive me if I dont understand the concept completely.

I am trying to use Max percent risk for forex but the cant seems to run a backtest successfully.

Here are some questions:
1. RiskStopLevel has to be entered in code? No drag and drop or other input feature?
2. In forex the margin is 1:50, so in WL do I set it to 0.02 to 1?
3. Movement in forex is small (eg 50pips), so when using small Max percent risk (1%), the lot size is in decimals. Can WL support this?
4. My backtest does not run any trades because of insufficient fund. What seems to be the problem?

Thanks!

I am trying it on a simple MA crossover system. Here is the code:

CODE:
Please log in to see this code.
profile picture

Eugene

#2
Welcome to the forums.

1. Yes, RiskStopLevel has to be entered in code.
2. No, Margin Factor is not the proper tool to set margin for Forex or futures (it's rather for stocks). Check out this KB article on how to set it up correctly: Working with Forex in Wealth-Lab
3. Lot size can not be in decimals i.e. be less than 1 unit. This is not supported.
4. Please see the FAQ explaining it: I'm using 100% Equity position sizing and strategy doesn't seem to use all capital and/or there are trades not included due to insufficient capital.
profile picture

chinwaihoong

#3
Hi, sorry for the duplicate of thread.

I had set the Max Percent Risk as 1%, but when I run the simulation I get trades with a Profit % worse than -1%.

What is the problem?

CODE:
Please log in to see this code.
profile picture

chinwaihoong

#4
Here is the screenshot
profile picture

Eugene

#5
There's no problem as I see it:

1. When stock gaps through your established Stop Level the position is getting closed at whatever price there is.
2. Your system has an AtMarket exit which naturally doesn't adhere to the established stop level as an exit. There's potential to lose more than the Maximum Risk that you established.
3. Commissions and slippage are applied (see Wealth-Lab's Preferences dialog).
profile picture

chinwaihoong

#6
Thanks.

But when I cross check with the chart, those exit worse than 1% is when the Fast Ma cross below the Slow MA and not from the risk stop level.

Is there anything wrong with where I place the RiskStopLevel, or anything wrong with my code?
profile picture

Eugene

#7
QUOTE:
But when I cross check with the chart, those exit worse than 1% is when the Fast Ma cross below the Slow MA and not from the risk stop level.

Exactly. That's what #2 in my response is saying and so is the QuickRef description of RiskStopLevel:

2. Your system has an AtMarket exit which naturally doesn't adhere to the established stop level as an exit. There's potential to lose more than the Maximum Risk that you established.

In other words, any non-AtStop exit not backed by RiskStopLevel -- such as your SellAtMarket exit -- has a potential to lose more than the % Risk defined.

P.S. On a closing note, this pattern is slightly more convenient:

CODE:
Please log in to see this code.
profile picture

chinwaihoong

#8
I'll try that. Thanks