Having trouble configuring Database provider for Streaming
Author: alexebrenz
Creation Date: 12/27/2011 2:32 PM
profile picture



I'm having trouble setting the database provider and the streamig. Below you see what I'm doing:

1) There is a table with 15 minutes data for historical and streaming bars
2) I've configured a new DataSet with Database Provider and with Data Scale = Minutes and bar Scale = 15
3) On Data Manager, on Database Provider Tab - set Up Streaming data I pointed to the same Dataset table. Symbol's box is empty I don't know why.
4) Under Preferences/Streaming Ticker Symbols I've inserted the symbols to stream the data
5) For both streaming and static the connection string is Server=; Initial Catalog=QUOTES_COLLECTOR; User Id=rm; Password=rm;Current Language=us_english;
6) The stream button is pressed on the chart. The message Streaming OK and the symbol is on the status bar
7) When I insert a new data for 15 minutes bar the chart is not updating
8) When I click on the symbol the chart updates and the bar appears
9) When changing from 15 minutes to 30 minutes or 60 minutes the chart is not compressing the bars. The same bars appears in all timeframes

Can someone help? What I'm doing wrong?
profile picture


The Symbols box is being populated every time you change selection in the Security Name field.

If the very same table is used as the streaming source and for symbol names as you say and the table uses exactly varchar() for symbol names, then the symbols should appear. Otherwise the whole streaming data affair is at risk.

After re-configuring the Data Manager tab, Wealth-Lab should be restarted for the streaming settings to be picked up by the Database provider (known bug). Try this step before continuing with #4 (and better eliminate #4 for now).

If still no go, give me an idea about your database table properties and what kind of time/timezone the data has (as already stressed in a support ticket, making sure the PC clock is synced is a must for normal operation of Streaming via the Database provider).
profile picture


Dear all,

I am now able to define one MySql database table as a Static Database provider - through the procedure detailed in this link: http://www.wealth-lab.com/Wiki > Providers > Database provider

The table I mentioned is updated (by another program) every 15 minutes.

This table has basically 5 columns (1:ID, 2:DateTime, 3:Ticker, 4:Close, 5:volume), and includes the very basic data that is enough to be used as a streaming provider. (And of course, i reviewed the columns' data types)


Things went ok when I first defined this DataSet as a static database provider (i.e. I am now able to see this ticker's chart as usual, and when I click the ticker occasionally, I see the chart updating itself with new bar data , perfect. The data is there, the connection is fine, and the chart is updated when I click the ticker and refresh the chart. Good so far!)


However, when I try to define this very same database as streaming provider, I had issues.

- I am trying to follow the very same procedure defined at this link: http://www2.wealth-lab.com/WL5WIKI/DatabaseProvider.ashx?NoRedirect=1#Usage_Notes_and_Limitations_5

- I can see the form (Data Manager > Database provider)

- THE PROBLEM IS THAT, the form allows me to enter the connection string, whereas nothing else becomes available (i.e. they remain empty). Thus, the select provider field cannot be filled, and consecutively all other options could not be selected, all remain empty. (but the connection string: I can edit this field),

- So, I basically cannot finalize the streaming provider configuration - for a database table which is successfully defined as a static provider.

- (to make myself clear, i attached one screenshot of this error. see the jpg)


What might be the issue here? How come i can define with no problem one database table as a static database provider , and cannot as a streaming provider?


And if it helps, my current setup is as follows:
PC: 64-bit, Windows
Excel: version 2007 / 32-bit (excel is involved in feeding this mysql table)
mysql: version 5.6 / 32-bit
wealthlab: version developer 6.6.13 / 64-bit.
ODBC connector: version: 5.2.6 / 32 bit (for excel/mysql connectivity i suppose)
NET connector: version 6.8.3. / 32-bit (MySql/wealthlab connectivity i suppose)

Two notes:
- First, I reached at such version/bit combination after long hours of trial and error. And I presume that, if this version/bit combination worked for me while configuring the static database provider, It should work as well for streaming database provider configurations. (Am I correct?)

- Secondly, when I click the `stream` button at the bottom-right of the screen (while the chart that is fed by this static database provider is open), my wealthlab totally crashes and returns `not responding` message. (See the jpeg)


Thanks in advance for your considerations and support.

best regards,

Aykut Saribiyik

profile picture


Sorry, I forgot to attach the second jpg as attachment.

Best regards,

Aykut Saribiyik

profile picture


Hi Aykut,

Please do a "Clear" first, or the dropdown box won't be filled with options. "Clear" is a must. Then you'll be able to paste your connection string and then choose MySql. Finally, don't forget to restart Wealth-Lab after changing Streaming settings.

You can not click "Stream" before the provider is configured, it doesn't make sense.
profile picture



It helped!!

I am now able to use this database table as both static and streaming data provider.

One suggestion: Maybe, the importance of clicking the clear button might also be highlighted at this link - where I suppose most of us begin learning about database providers.


The modification to this link and adding the "push clear button" might be helpful to users, and would save your valuable time.

Thanks one again,

profile picture


Thank you for the heads-up. Note has been added to the documentation.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).