Fidelity data 0 bars when updating SPY 1 minute DataSet
Author: ogunbey925
Creation Date: 5/31/2018 3:36 PM
profile picture


I am recently having this issue where I am updating data on demand and it does not update my 1 minute SPY etf data.

This is what I see on the Data update log

SPY 0 bars No data 0 bars added

I get no data when I run a strategy on this data...but it comes over if I enable streaming data....but it doesn't keep the streamed data if I close the application.

The daily data comes in fine in my other datasets.

Any solutions would be much appreciated.
profile picture



1. Does it affect SPY only? Try to add more symbols to the 1-Minute DataSet and update it. What do you see in the update log now?

2. After enabling hidden file visibility, delete this folder:

C:/Users/AppData/Roaming/Fidelity Investments/WealthLabPro/Data/FidelityStaticProvider/1 Minute

Now if you update SPY from scratch, will the big file SPY.WL be created there?
profile picture



1. Adding a new symbol didn't do the added/updated the new symbols but didn't added to the SPY symbol.

Updating Provider Fidelity Investments ...
Updating 1 Minute data ...
OEX 1404592 bars 5/31/2018 2:28 PM 1404592 bars added in 89 chunks
SPY 0 bars No data 0 bars added

2. but by deleting the folder that contained the symbol I was having a problem did the trick.


profile picture


Good to know that it helps. I think that the issue was caused by the corrupt SPY.WL file which aborted data update.
profile picture


I have walked through these directions and it did not help. other tickers load perfectly.
Do you have other suggestions?

I have a free version of Wealth Lab from fidelity, its 6.9 64 bit.
Ive been using about a month. 1 minute SPY chart won't load previous candles except current day. all other tickers Ive tested do this. SPY was working for me until a week ago. I have number of candles to display at 777

Please advise. Ive cleared data set, restarted, entered manually, etc.

Error is No Data Available
profile picture


1. Set the data range to "All data". Does it work?

2. If [x] Data range is checked in the Preferences dialog (hit F12) > Advanced Options > "Save the following items with a Strategy...", uncheck it. If it doesn't work...

3. Right click on your 1-min DataSet with SPY, click "Symbol Details", right click on SPY, choose "Reload symbol data file". Now update the DataSet to reload the SPY data. Open up a 1-min chart of SPY and set the data range to "All data". What are you seeing?

If still no go you would want to add a detailed description of all steps taken and attach a screenshot to illustrate.
profile picture


1) when I checked all data it loads a chart from 2005, pics attached.

2) I believe this is correct?

3) still same 2005 charts
profile picture


Try adding your image attachment again... make sure it's the full workspace.
profile picture


thanks, I got it working by going through your instructions again.

Thank you very very much!
profile picture


Glad to have helped.

I had no doubt that you should be up and running soon :)
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).