Error message "Strategy code must set RiskStopLevel in order to use Maximum Risk position size."
Author: pejacobson
Creation Date: 5/8/2015 8:59 AM
profile picture

pejacobson

#1
I am new to Wealth Lab Pro, having just downloaded and installed it from Fidelity's website.

I am going through Fidelity's video tutorial and am currently learning about running pre-built strategies.

I've only tried two so far: Darvas and Moving Average Crossover. With both of these, when I use the % risk position sizing set to 1%, I get the following error message: Strategy code must set RiskStopLevel in order to use Maximum Risk position size.

Has anyone else run into this error? Can you offer suggestions?

I don't see RiskStopLevel as a parameter setting, and I don't see this variable in the code, so I'm puzzled. But, as a new user just learning the code, I am probably making some very basic mistake.
profile picture

Eugene

#2
Welcome to the forums Paul.

According to the RiskStopLevel entry in the QuickRef (F11 key):

QUOTE:
If you select the Maximum Risk Pct position sizing option and do not set RiskStopLevel in your Strategy code, you will receive an error message when attempting to run the Strategy.


Neither one of these strategies assign a RiskStopLevel; consequently, they can not be used with this position sizing option without a slight modification. Only one preinstalled ("Channel Breakout VT") and about a dozen downloadable Strategies set RiskStopLevel.

More information can be found in these discussions:

Risk Based Position sizing
How to set RiskStopLevel?