Error in Trade Graphs Visualizer
Author: ronc
Creation Date: 6/18/2014 10:03 PM
profile picture


Create a New Strategy from Rules. Did not touch the code (below). When run it produces this error:
Error in Visualizer: TabPage: {Trade Graphs}, removing.
Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index

All extensions are up to date. WLPro 64-bit. Same error occurs on other strategies built from rules.
Please log in to see this code.
profile picture


The strategy works for me, including all tabs of the "Trade Graphs" Visualizer. I ran it on several portfolios. I didn't build it, just copied your code above.

The first trade was at 8/17/2009. That may be the start of ESS data.

I also run WLPro 64-bit, on Windows 7 platform
profile picture


This is all about data, I think. A delisted symbol in your DataSet, for example, or a similar issue may be throwing this.


+ Different data ranges
+ Other DataSets
+ Check your DataSet's integrity with the Data Tool
+ Single symbol / multi-symbol mode
+ Change bar scale

...until you find a clue. Let me know once there's a reproducible scenario.
profile picture


I isolated the issue to occur or not based on data range. Tested on the Dow 30 DataSet (daily) (updated/current). RP mode. Time scale = daily. Start date = 1/1/2013. Via manual iteration I found that if End Date = 2/27/2014 or earlier it runs OK and if End Date = 2/28/2014 or later it produces the error. I am guessing that some fundamental data ended on 2/27/2014. So I guess I cannot test after 2/27/2014.

Is there a way to check the ranges of such data to avoid this trial and error going forward?
profile picture


Thanks. Wealth-Lab Developer isn't updated to 6.7 yet and I don't have access to the Fidelity fundamental data (i.e. "equity summary score"), so my tests are based on other fundamental data sources. The tests I ran on Dow 30 (Yahoo! data) with various end dates and fundamental items by MSN and Morningstar didn't result in a visualizer error.

1. Is the problem only with the WLP-only ESS data or other fundamental items by Fidelity?
2. How about non-Fidelity fundamental data items (there's half a dozen other providers)?
3. Can the error be isolated to the Trade Graphs visualizer or other MS123 visualizers may also throw this exception?
profile picture


Not sure I can answer these. I went to Tools > Data Manager, checked all boxes, updated Dow30 data set, reran, got same result. Yahoo and MSN are there but not the others at your link above. I followed the link above and it leads me to pages such as:
... but I could not find information in those pages on how to install these data providers? How do you install them?

On question 3, how do I test this?
profile picture


Okay, we will skip 2 and 3 as they may be secondary to finding the culprit (and especially considering that installing extensions and enabling/disabling visualizers is thoroughly documented in the User Guide).

I went to Tools > Data Manager, checked all boxes, updated Dow30 data set, reran, got same result.

This gives rather a good clue, hinting again at the ESS data and at the same time removing suspicion from the static data. So to reiterate what I actually was suggesting you to do in #1:

1. Update all of your Fidelity fundamental data,
2. in your strategy, change the "equity summary score" (ESS) to other fundamental items to collect statistics,
3. notice if all fail the same way, or only some (which?), or maybe only the ESS again.

You said that Same error occurs on other strategies built from rules. Which other, exactly? Those using Stochastic and Moving Average or maybe those that utilize Fidelity's fundamental data?
profile picture


I did this:
- Data Manager > Update Data > Checked all Fidelity boxes, unchecked all others.
- Data Manager > Data Sets > Selected Dow 30 (scale daily).
- Data Manager > Update DataSet.
- Opened my rules-based strategy.
- In rules editor, changed ESS to to: Fidelity Estimated Earnings.
- Ran, got same error.
- In rules editor, changed Fidelity Estimated Earnings to to: Fidelity net insider transactions.
- Ran, NO error.
- In rules editor, changed Fidelity net insider transactions to: Fidelity short interest as % of shares outstanding.
- Ran, got same error.
- In rules editor, changed Fidelity short interest as % of shares outstanding to: Fidelity net insider transactions (which I ran previously).
- Ran, NO error. (although previously this DID produce an error).
profile picture


Thanks for the information. So the issue is intermittent.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).