Any way to improve display appearance of WLP?
Author: supermagnetman
Creation Date: 4/23/2019 11:21 PM
profile picture

supermagnetman

#1
I have a Dell XP Windows 10 computer with 16 GB ram and 4K display. I have tested the display settings at all of the available windows settings and all it does is shrink the screen and make the menu bars gigantic. All of the dialog boxes in WLP are only showing the upper 1/4 of each item. I have to click the ? on each item to get it to pop up the actual name or the same for any values. I asked about this about a year ago and I hate to see a program that has so much potential to have the worst user interface I have ever seen on any computer since the late 1970s.

Thanks
George
profile picture

supermagnetman

#2
To further explain you can see the attached images of the crappy UI that is on my Dell XP display. I have tried almost all of the screen resolutions that MS sees fit to include and nothing changes this crappy interface. 800x600, 1024x768, 1440x1080, 1920x1440 and on up to the screen max.

While functionally the program looks like it can be useful this interface is light years away from being useful. Once again today I submitted it to Fidelity to prod their development team to work on. My computer is about 2.5 years old so it is very powerful but not the latest thing available.

If anyone has any ideas that can help me get this looking a little better I would certainly appreciate it.:)

The only way I am able to use it is with 2 pair of 3.0X glasses stacked together and with a printed copy of the manual to tell me what the 2 pixel high choices are and then try to click on it and see what happens.
profile picture

Eugene

#3
George,

Unfortunately, the issue you've encountered is well known. Searching the forum for many keywords like "display, screen, font..." should reveal many topics which point to the same solution in our Knowledge Base. Anyway I'll repeat it here.

The problem may appear as font size being too big or too small, text hard to read, overlapping labels, Strategy parameters 'missing' or cut off and so on. Please follow this quick and easy guide to fix it: Fix Wealth-Lab Fonts in Windows 10.

On Windows 10 the most promising option is to right click on Wealth-Lab's shortcut, select Properties, then under the Compatibility tab set 'Disable fullscreen optimizations' or set 'Override high DPI scaling behavior' to 'System'. For more information refer to Open Issues > (146) Application needs to support 120 DPI throughout.

P.S. When you upload a screenshot simply do the following:

1. Press Prt Scrn key on your keyboard
2. Start MS Paint (built in Windows)
3. Strike Ctrl-V to paste the image
4. Save in PNG format (JPG is suboptimal)
profile picture

Eugene

#4
P.P.S. Actually a couple years ago you had created two tickets where I provided a detailed explanation along with suggestions for a fix, and later the easier guide emerged - "Fix Wealth-Lab Fonts in Windows 10".

https://www.wealth-lab.com/Support/Ticket/28100
https://www.wealth-lab.com/Support/Ticket/28103

profile picture

supermagnetman

#5
Eugene
Yes a couple of years ago I tried getting it to work and it never did work. Still I got some success from the analyzes I ran and then the market wasn't a lot of un for a while. Now I have some time and wanted to get back to using it. I was hoping something would have happened to improve the display. Thanks to your tips and dozens of trial and error attempts with many many settings - I think it is useable. - YAY - Thanks for your patience and the new ideas:)


George
profile picture

Eugene

#6
George,

You're welcome. We hope this super annoying issue gets fixed sooner rather than later.
profile picture

Tims

#7
It may not pertain to your situation and computer set up but I was experiencing the same annoying issue with a Microsoft Surface Pro that uses an abnormal screen resolution(2736 x 1824). I had to use a much smaller resolution to get it to get usable until(with WealthLab started first, this is important or it didn't work.) I plugged a 2k monitor in via DisplayPort. When I did that not only did WealthLab scale correctly on the 2k monitor it changed the Surface Pro resoluion back to the recommended and scaled correctly on there. So you might be able to start WealthLab then unplug and plug your monitor back in. Hope this helps you or someone else.
profile picture

supermagnetman

#8
Tims

Thanks - yes my max resolution for my Dell notebook is 3840 x 2160 and after sequentially trying a lot of the combinations it turned out that 2048 x 1152 works pretty well. For the first time I can actually see the menus and dialog boxes:) It is a whole new experience:)


Thanks
George
profile picture

Eugene

#9
@Tims

Thanks, added your suggestion to the Open Issues page as a potential workaround.
profile picture

Tims

#10
George,

I'm glad it "worked" out for you. I forgot to add that when the 2k monitor is plugged in it changes the Surface Pro back to the max resolution as well as the max monitor resolution and scales WealthLab correctly but when I unplug the monitor the Surface Pro resolution goes back to being smaller and WealthLab scales back down. Also when WealthLab is started after the monitor is plugged in it does not scale correctly so I have to unplug and plug it back in, it's pretty surprising that it works so well. So if you have a second monitor you might try plugging it in and see what it does for you.

Eugene,

I would like to know if what I detailed above about a second monitor can be replicated and works on other machines. Thank you.
profile picture

Eugene

#11
I don't have appropriate hardware setup for replicating it. Multiple monitors have their issues; see this for example - Wealth-Lab or one of its windows is not displayed. Anyway, eventually this issue known as QC 146 gets approached. Maybe it will have some effect on what you described, can't tell.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).