4K screen and text/icons are tiny
Author: sirgrinalot
Creation Date: 9/30/2016 1:40 AM
profile picture


Mostly in the title, I have a screen that is 3840x2160 resolution running Windows 10 anniversary update and windows scaling set to 150% with the 64bit version of Wealth-Lab Pro. Upon first boot up of the application all the icons and text are very tiny and if it stays like this my eyesight will be gone in a matter of weeks/months.

Is there a way to fix this? I've looked through the preferences and couldn't find any in application settings for text and/or icon size.


profile picture


Please see the Open Issues page in the Wiki on ways to alleviate this:

(146) Application needs to support 120 DPI throughout
profile picture


I have the same problem. Nothing help to fix this issue.
profile picture


Well, it's helpful to the legitimate users of actual versions. No support for you and the cracked version of Wealth-Lab you're using. Good luck.
profile picture


Hi Eugene,

We tried the setting but it does not work. I also tried to install net 4.6 framework, but for sure it does not work as i have a newer one. Is 4.6 required or just the minimum version?

If the screen-resolution does not work, can we reset the key? as it makes no sense to use that in that way..

profile picture


Hi Matthias,

1. From my own recent experience, that EnableWindowsFormsHighDpiAutoResizing option doesn't work. Forget it by now.

2. At all rates, check "Disable display scaling on high DPI settings" checkbox.

3. Then you could use "Medium - 125%" DPI but lose the Strategy Parameters box or revert to 100% DPI (with tiny fonts) and change the font size of individual items in Windows Control Panel one by one (title bar, icon text, etc.)

That's all I know.
profile picture


After many frustrating months and many failed attempts to get WLP usable on my Dell xps 13 laptop, I finally succeeded. The solution employees a .manifest file as explained at the following website ...


(Although the headline mentions Adobe, the technique seem to be generic.)

After making the Registry changed it specifies, I clicked the link in the line "Here is a link to a txt file with the manifest code: manifest.txt". Hi lighted all the text on the resulting page, copied, then pasted it into Notepad. Saved it into WLP Program folder as WealthLabPro.exe.manifest. or WealthLabDev.exe.manifest for WLD - Eugene

Started WLP & it was beautiful ... looking just as it does on my desktop.

BTW, I encountered a similar display issue with Microsoft Streets and Trips 2013. Having realized the content of the file is not application specific, I copied WealthLabPro.exe.manifest to the Street and Trips folder. Renamed it Streets.exe.manifest and Streets and Trips displayed just as it had on my previous laptop & desktop.

If it solves the problem for others, you might want to click the donate button as I did.

profile picture


Thank you for sharing. Seems like an excellent find. I'll give this solution a try soon and see if it replaces the Wiki workarounds.
profile picture


Got mixed results. System refused to accept the .manifest file due to an error. Despite having saved it as UTF8 as one of the commenters suggested. I guess it's due to the .manifest's contents which has to be tweaked for WLD/P.

But the big news is what Dan Antonielli (article's author) wrote in a comment on April 8, 2017 at 8:30 am:

There is no need for this ‘fix’ with the Creators Update.

Microsoft has now baked this into Windows. After right clicking and selecting ‘properties’ for the application you want to scale…. You will find ‘Override high DPI scaling behavior.’ under the ‘Compatibility’ tab. Select ‘System’ from the drop down.
profile picture


Yesterday I forced an upgrade on my Dell XPS 13 laptop to creators edition. Went without any issues!

Started WLP and was surprised to find the awful looking version was back. Checking the various elements of the solution, I found the problem ... the upgrade had wiped out the "PreferExternalManifest" registry entry.

Figuring this was what I needed to test the new " ‘Override high DPI scaling behavior’" mentioned above, I altered WLP properities and started it again. Disappointment ... some improvement, but still not good. (btw, I had also removed the .manifest file from wlp folder).

So, back to Dan Antonielli's solution. Put "PreferExternalManifest" in registry and the manifest file into WLP folder. Unchecked the Compatibility setting and started WLP. It worked ... all the elements of the user interface were properly rendered ... looked just like the one on my desktop.

One final test ... I left the manifest fix active & checked the Compatibility setting. Not good ... appears the Compatibility bypasses the .manifest processing.

I've attached the screen shots associated with the above.

Eugene, I don't believe the .manifest content is application specific. I may be display dependent, don't know. As I mention in my original post, I did nothing more than copy the text to Notebook & save with the specified name. Since the initial success with WLP, I fixed 2 other applications. In both cases all I did was copy the .manifest file from the WLP folder to the apps folder, then rename with the .exe name of the app. In both cases, worked perfectly with no other changes.

profile picture


Thinking that I might have overlooked something, I retried Dan Antonielli's procedure. Made sure that PreferExternalManifest has been in the registry. Reviewed the manifest file structure in Notepad++. WLD doesn't start.

On my Windows tablet, certain apps (and for some reason WLD is no exception) are run from an encrypted volume to quickly take out and destroy in case of necessity. So I decided to override this security policy and copied the WLD folder onto tablet's eMMC drive (sort of built-in SSD) where Windows is installed, and start WLD from there. Still no go. If the manifest file is nearby, I get an "Access denied" error which disappears if I delete the file.

I suppose the problem may be rooted in my tablet or its Windows version.
This website uses cookies to improve your experience. We'll assume you're ok with that, but you can opt-out if you wish (Read more).