- ago
I am running Wealth-Lab 7 on two different computers using the exact same strategies, data provider, time frame, parameters. But the results/metrics reports are different (APR, minimum periodic return, etc.). How come?
0
91
Solved
6 Answers

Reply

Bookmark

Sort
- ago
#1
The results can even be different on the same computer if you run the same strategy multiple times. If this happens the most likely explanation is there are too many signals for the simulated equity, in which case the default behavior is to choose which signals to "fill" randomly.
0
- ago
#2
We even have this in the website FAQ under Support:

"Every time I run a Strategy I get a different result. Why?"
https://www.wealth-lab.com/Support/Faq

One thing to check is the data. It can be different between your two PCs. For example:
https://www.wealth-lab.com/Discussion/Testing-S-amp-P-500-with-Wealth-Data-6925
0
- ago
#3
Make sure your backtest preferences match exactly. I had this same problem until I took screen shots to match all preferences (slippage, commissions, check boxes, etc) exactly. Now I am able to match backtest results shared between my desktop and laptop.
1
- ago
#4
Also to extend on arflouro82's point, you can Export the strategy and then import it on the other PC.
1
Best Answer
- ago
#5
I had a similar issue; did all the usual checks and balances and could not find the cause in WLD, Preferences, Strategy Settings etc.

In a last ditch effort I decided to remove all local data and download fresh.... problem solved. <-- hope this helps others troubleshoot the issue if encountered.
0
- ago
#6
QUOTE:
In a last ditch effort I decided to remove all local data and download fresh.... problem solved. <-- hope this helps others troubleshoot the issue if encountered.

Yes, data vendors may apply adjustments so to make a robust comparison it takes to refresh the data on both devices.
0

Reply

Bookmark

Sort