- ago
Small Bug:

When selecting the right click option Push these Parameter Values to other Visualizers on the Optimizer Tabular results the One-Paramter Graph tab default parameters are update, but the Surface Graph default parameters are not.

Build #: 25

1
84
Solved
9 Answers

Reply

Bookmark

Sort
- ago
#1
Image for reference.

1
- ago
#2
Which optimization method did you use? Read the red text to see why it could not populate.
0
- ago
#3
Optimizer type was Shrinking Window.

I found the red text a little cryptic. How could the values transferred from the tabular list be "outside the step values". They had to be inside the step values in order to be "results" from the optimization process.... hence your question "which optimizer was used" (no doubt).

After further exploration I believe I now understand why this has occured. Here are my thoughts....

Firstly, (and a perhaps a little trivial) I don't believe the cause of the red text notice should result in aborting the transfer of values to the text field boxes/sliders. The two functions are seperate. One is the transfer of values, the other is the notification that the values transfered may not result in data showing on the graph.

Second, the only value i could find NOT within the optimizer step values was infact a non-optimized value. This was the %equity allocated to the trade. Therefore ALL optimizations had the same %equity paramter value. I believe the determination that it is not within the stepvalues is technically in error. Rational below.

First, let me explain how I got this end result....

Steps for setting up my optimization.

1) Load strategy and set optimizable parameters in entry building blocks

2) Set equity % value and % equity as optimizable on strategy settings tab
2a) Ran optimization on DOW30 with %equity parameter unchecked as optimizable on Optimization settings Tab.

3) This is where I unknowningly introduced this issue: After reviewing first optimization I decided to reduce the equity percent and broaden the market.

I reduced the strategy default settings and default parameters on the Strategy Settings tab and selected a larger data set - but did not adjust the lower threshold of the optimizable config for the % equity param to correspond with the new strategy and default settings.

Images below show strategy settings, optimize step value configuration and default strategy parameters.




4) I selected shinking window optimizer and unchecked the % equity on the optimizer settings as I was interested in impact of smaller allocation on number of trades entered and the stability of the equity curve as a result of more diversification.



5) Run the Shrinking window optimizer

6) Right click on tabular list of optimization results and click "push values to other visualizers"

If I understand correctly, technically the lower threshold of the step values as configured in the strategy settings for the optimizable paramter of % equity is causing the red text and parameter not to transfer - because the default value used is lower than the stepvalue start.

ie: (0.05 < 0.125) or (default value < stepvalue start)

However, in this scenario the parameter is not optimized and therefore the value transfered is infact within the upper/lower limit.

Rationale: When the parameter was unchecked for optimization the default value became the upper and lower limit. Therefore the value being outside the configured strategy stepvalues should not impact the return of data as all data uses the strategy default value.

Image below shows optimizer results with the same %Equity.



Obviously the immediate solution is clear. Adjust the strategy % equity optimizable parameter configuration to match the default. However, being an easy setting to miss, perhaps a warning message on the optimizer settings tab might be helpful, if not an override in the surface graph step-value check routines


1
- ago
#5
Thanks for submitting such detailed and thought out bug reports.
0
- ago
#6
Hope it helps.
0
- ago
#7
Hmmm, maybe we can check to see if the default value is within the stepwise range, and if not, assume the first value instead.
0
- ago
#8
We have improved this and it's now working better for B27:

2
Best Answer
- ago
#9
Excelent, thank you.
0

Reply

Bookmark

Sort