Yahoo! Data Update Error (Reprise) [Fixed]
Author: Cone
Creation Date: 12/31/2013 3:42 AM
profile picture

Cone

#1
If you're seeing "Error: Unable to connect to the remote server" for your Yahoo! update today, hopefully it's just another case of an intermittent availability. For more information see:

Yahoo Data Update *didn't* work
profile picture

Eugene

#2
Got no error when updating my Y! data earlier today.
profile picture

Cone

#3
Earlier it worked... right now it does not.
profile picture

Panache

#4
I'm getting "Error: The underlying connection was closed: An unexpected error occurred on a receive." when I tried to update my Yahoo data both this morning and again now. Is this a version of the same error Cone is getting, or is it something else?

You might also want to check this out. http://www.mathworks.com/matlabcentral/answers/111141 It suggests that Yahoo has changed it's server address.
profile picture

Eugene

#5
Same here: you can get an "Unable to connect", Error 504, or "Underlying connection closed" error.

Bad news: I have just determined a change in the data download URL. Lately, Yahoo made some overhaul of their website - that could be a part of it.

Good news: We'll keep an eye on the situation to determine if it's a temporary glitch or we have to release an immediate fix to the Yahoo! provider.

For now, you may want to switch to a backup provider.
profile picture

ReneW

#6
A different trading software, which uses Yahoo too, did not have these problems.

To me it really seems like a WealthLab Yahoo Provider problem.

Happy New Year!
profile picture

Eugene

#7
Thanks and happy New Year.

That different trading software must have already been using the updated download URL for some time. The Wealth-Lab provider has been using the old URL since inception. Expect the fix later today or tomorrow.
profile picture

Eugene

#8
UPDATE:

The problem has been solved in build 2014.01. Users are encouraged to update to the latest version.
profile picture

AgentFF

#9
hi there,

tried to update and received an error message reading: "Error 404 during updatge of data provider extension".

like described here:
http://www.wealth-lab.com/Forum/Posts/Problem-Error-404-during-update-of-data-provider-extension-33303

as an alternative I tried to download the file directly to my computer and open it with the extension manager. Unfortunately this wasn't working too.

Anyone having an idea how to solve this issue?

Any support is highly appreciated.

Happy new year!!


regards,
Florian
profile picture

novendeh

#10
Eugene - when I try to update from V 6.6.13 to 14.01 using Software Upgrade under the Help Menu, it tells me Software is up to date. How do I update to get Yahoo Quotes working again? What am I missing? Thanks.
profile picture

Eugene

#11
AgentFF

Updating will not work as your Wealth-Lab version is outdated. More details available if you search the forum, typing in "error 404" in the search box:

ATTENTION! "Error 404" when installing/updating extensions

In short, please update to the latest version 6.6 to be able to download extensions.

novendeh

On how to install/uninstall/update Wealth-Lab extensions, please review this illustrated tutorial and/or check out the Wealth-Lab User Guide > Extension Manager.

Now, there's a problem with updating certain extensions that affects WLP customers (only). To install the updated Y! provider, follow these steps:

1. Open 'C:\PROGRAM FILES\FIDELITY INVESTMENTS\WEALTH-LAB PRO 6\' in Explorer and uncheck the Read-Only attribute of WealthLab.DataProviders.Yahoo.dll.
2. Uninstall your 1.3.11.0 version of the Yahoo! Provider
3. Install the 2014.1 version from the website.
4. Restart WLP.
profile picture

novendeh

#12
Thanks, Eugene. I missed it was an update to extension manager and not Wealth-Lab.
profile picture

Tobey

#13
Hi Cone,

I went to update Yahoo Finance Static Real-Time and Fundamental 1.3.11.0 New Version 2014.01.01. I hit update and then restart Wealth-Lab and it didn't work.

Now when I open Wealth-Lab Pro the Extension Manager window comes up then I get a sceen saying Wealth-Lab Pro has stopped working and the program closes.

I reinstalled the program using a current download from Fidelity but that didn't fix it.

I see these 2 errors in the log

2014-01-02 09:38:55,852 [1] ERROR WealthLabPro.ChartForm [(null)] - Collection was modified; enumeration operation may not execute.

2014-01-02 14:35:24,949 [EMS Session Dispatcher (608248)] ERROR WealthLab.DataProviders.FidelityBrokerProvider [(null)] - Error in Shadow post alert for Balances SPBSM
System.NullReferenceException: Object reference not set to an instance of an object.
at WealthLab.DataProviders.FidelityBrokerProvider.a(XmlDocument A_0, String A_1, String A_2)

What do I need to do to get Wealth Lab up and running again?

Thanks for the help
Tobey
profile picture

Cone

#14
QUOTE:
I went to update Yahoo Finance Static Real-Time and Fundamental 1.3.11.0 New Version 2014.01.01. I hit update and then restart Wealth-Lab and it didn't work.
There are a couple posts above describing how WLP customers need to update the Yahoo! Provider. Here's a small simplification though...

1. Close WLP
2. Open 'C:\PROGRAM FILES\FIDELITY INVESTMENTS\WEALTH-LAB PRO 6\' in Explorer and DELETE WealthLab.DataProviders.Yahoo.dll (Admin required)
3. Install the 2014.1.0.1 version from the website.
4. Restart WLP.

Now back to the "Stopped working" issue. The first thing to try is to eliminate your Default workspace. In ..\Data\Workspaces (as in C:\Users\Tobey\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\Workspaces), rename the Default.ws file if it exists. Start WLP.

If that didn't help, try renaming the \Data\ folder just to see if you can get running again.

Also, if you have both 32 and 64-bit versions installed, make sure you're launching the one you think you are.
profile picture

Tobey

#15
Hi Cone,

Thanks I got it done. I had to restore a backup of the data from last weekend. Then I could follow your instructions above.

I also had to use the same instructions for TASC Magazine Indicators.

Thanks again for the help
Tobey