Windows 10 PC will only update 1 minute data
Author: bgood
Creation Date: 5/9/2016 10:53 PM
profile picture

bgood

#1
Hello guys,

I have multiple PC's and other machines work properly. A few days ago, 1 machine stopped updating all data sets except for Fidelity 1 Minute data. I have many datasets from multiple providers. How do I get my machine to update again?

BTW, if I select an individual dataset and UpdateDataSet, everything works as expected.

Regards,

Bryce
profile picture

bgood

#2
An additional bit of data. I had added more 1 minute symbols in the past few weeks because of testing. I was up to 230 symbols with 1 minute data. I noticed that the Log directory had files in it with "Overflow error" in them. I deleted about 1/2 of the 1 minute symbols and update now works. Can you please explain this behavior?

Bryce
profile picture

Eugene

#3
Hello Bryce,

There's not enough detail to explain this behavior. To start with, we don't know the providers and bar scales which failed to update, what kind of error message(s) were in the data update log (or were they absent), and whether the provider extension(s) are up-to-date. The more evidence the better.
profile picture

bgood

#4
Hello team,

I had the problem happen again where my update would not work, and I have more information. It turned out that 2 symbols DUST and JDST both had a 10:1 split. I had 1 Minute and 15 Minute versions of those symbols. I needed to delete the data files for DUST and JDST then the update would work again and only reload the deleted files.

Bryce
profile picture

Eugene

#5
Thanks for the update Bryce. Still, it's not clear what was happening:

1. The symbols you've deleted, which provider do they belong to?
2. How exactly would your update "not work"? At what point did it stop? Any specific error message?
3. Which historical providers are checked for update?
4. Have you updated all of the installed providers' extensions?
profile picture

bgood

#6
The symbols are Fidelity.

Not work: When an update starts, the process chugs along normally until the split happens. There is a message about processing the split, then the update stops. The update will never proceed further.

Today's problem occurred on all machines. Different machines have different sets of providers, but Fidelity, Bloomberg, and Yahoo appear on all.

All extensions and WL are current!

One interesting observation (maybe related or a second defect that I have not characterized yet), is that my 1 Windows 10 Home machine has problems displaying the trend lines when used with a complicated strategy. What I have observed is that I convert interday data to weekly data, then do an EMA.Series on the results. Unless I use 48 months of data, the trend lines disappear, and the annotations I place on the chart disappear. It makes me wonder if there is a bad dll that I am loading on that machine. Another machine does not have the problem when using the exact same strategy. Given the same version of WL, Windows 10 (pro on one, home on one), same versions of the extensions, and same strategy, you would expect very similar behavior. The 2 things that could be different are 1) different versions of DLL's used by WL and 2) different video cards and drivers. If it is a DLL issue, then it may be related to this problem. However, because both machines demonstrate the split-update-problem, I am inclined to dismiss this as a DLL issue.

Bryce
profile picture

Eugene

#7
Re: update stops. Thanks for clarifying this. Sounds like broken data file - perhaps a *.WLF containing splits.

Re: disappearing drawing objects. Unless the data on your PCs is in synch by either using a network share or physically copying the *.WL files from one machine to another, it's assumed that both have slightly different data by virtue of such factors like missing corrections, data errors etc. A chart drawing object can be defective, too. Different video driver/card may play a role. To prove or discard, I'd sync the entire WealthLabPro folder from %AppData% from the PC that doesn't have the problem.
profile picture

kazuna

#8
I ran into exactly the same problem on my two Windows 10 machines.
Interestingly my other three Windows 7 machines are working fine without the problem.
It all started after DUST split and only happened on Windows 10 upgraded machines.
1 minute data update worked but Daily data update completely stopped working.
I have since deleted all data files under FidelityStaticProvider folder and the problem goes away.

So be careful if you have recently upgraded to Windows 10 and have a DataSet with split Daily symbol.
profile picture

Eugene

#9
Thanks. So you haven't deleted the fundamental data store, just the static folder?
profile picture

kazuna

#10
Yes, just static folder excepting the three txt files in it.
profile picture

Eugene

#11
A note has been added to the Open Issues list. Potential ideas to try if someone is affected by the issue:

1. Reload only the split symbol's EOD data (right click on the instrument's chart and select "Reload chart history")
2. If not possible to determine the failing symbol, mass reload Fidelity's static data DataSet by DataSet using the Data Tool.
profile picture

kazuna

#12
I just realized that some symbols have stopped updating since July 22.
It turned out due to VIXY split happened on July 25.
I had manually reloaded not only the split symbol but also others in order to get the symbols up to date.

This is really painful and it makes strategy unreliable.
From now on, I'm monitoring all stock split announcement.

Do you have a plan fixing this in the next release?

By the way, this is not only daily data but 1-minute data also fail to update.

>Fidelity data can not be updated except for 1 minute. Update All Data stops after a message about processing the split.
So this is not accurate.
profile picture

Eugene

#13
I regret that you're having trouble with this. It appears that reverse splits (for example, like ACLS with which others have had problems) break the Fidelity static provider. Keeping an eye on stock splits is a correct decision so here's a resource that can be easily parsed and monitored:

INO.com Recent Stock Splits

As you could find on our Open Issues list (see Data section), this bug is already known and reported to Fidelity. There you also have 3 workarounds. As we (MS123 LLC) are not directly involved in development of the Wealth-Lab client, there's no ETA or a plan that we can share at this moment.
profile picture

kazuna

#14
Thank you for the link. Any idea why VIXY split isn't listed in there?
profile picture

Eugene

#15
No idea (although it too was a reverse split). You may want to check other sources like Nasdaq - Upcoming Splits or the solution integrated in Community Components: WL Wiki - Upcoming Splits.
profile picture

kazuna

#16
Unfortunately, Upcoming Splits doesn't seem supporting ETFs.
profile picture

Eugene

#17
But Nasdaq website does. Here's a quick script that parses the page and returns the upcoming splits calendar. Make sure to a) have HtmlAgilityPack in the WLP main folder and b) check System.Xml and System.Core in the Editor's "Add References..." dialog:

CODE:
Please log in to see this code.
profile picture

kazuna

#18
Thanks Eugene for the code.

By the way, according to WL Wiki, it says:
QUOTE:
Delete all directories in the FidelityStaticProvider folder in hidden directory C:/Users/AppData/Roaming/Fidelity Investments/WealthLabPro and reload static data.
How about wiping out FidelityStaticProvider folder everyday right before the scheduled automatic daily update?
I don't have to worry about stock split after all. Right?
profile picture

Eugene

#19
Sounds like a reasonable idea. Please try and give us an update. Note that reloading the entire folder with hi-frequency data might take a while.
profile picture

kazuna

#20
Do you think I can delete these files under FidelityStaticProvider all together?

SymbolErorCountList.txt
SymbolManagementProperties.txt
SymbolQuarantineList.txt

If so, I can delete FidelityStaticProvider folder completely and the scheduled automatic daily update will recreate the folder, correct?

--------------------------------------------------------------------------------------------------------------

I deleted "1 minute" and "Daily" folders under FidelityStaticProvider folder but Automated Data Update doesn't update them.
It says "Update completed" but no symbols are updated.

Next, I deleted FidelityStaticProvider folder but the same result.

I have many data sets and I don't want to reload one by one.
Any idea how can I get all symbols to be updated at once?
profile picture

Eugene

#21
QUOTE:
It says "Update completed" but no symbols are updated.

I recall this happens sometimes, you might need to restart WLP before updating again.
profile picture

kazuna

#22
I did restart WLP number of times but WLP never ever updates the dataset.
Once I copy back "1 minute" and "Daily" folders, WLP updates them.

--------------------------------------------------------------------------------------------------------------

I found something interesting.

First I delete "1 minute" and "Daily" folders under FidelityStaticProvider folder.
Then tried the following two cases.

[CASE A - UPDATE FAIL]

I have strategy charts on Default workspace.
When I start WLP, WLP asks to login.
I open Data Manager and click "Update all data for selected providers now".
Update completes immediately and no data updated.

[CASE B - UPDATE SUCCESSFUL]

I remove Default.ws.
When I start WLP, WLP doesn't ask to login but just opens bare window.
I open Data Manager and click "Update all data for selected providers now".
Update starts updating all data.

Is this expected?
profile picture

Eugene

#23
Thanks for reporting this.
QUOTE:
When I start WLP, WLP doesn't ask to login but just opens bare window.

Your default workspace contains one or more elements that require authentication such as: Strategy Monitor running an intraday strategy (1-10 minute), Accounts tool, a Streaming chart or strategy etc.
QUOTE:
Update starts updating all data.

I'm not that familiar with WLP now so am not sure if I heard of this before, maybe Cone already knows something? Looks like the failure to update is somehow tied to the authentication cookie or something like that.
profile picture

kazuna

#24
This is not limited to Default workspace but opening other workspace also makes the update does nothing (completes but no real data update).

So it looks to me if opening workspace and failing chart strategy (index out of range exception due to no data) causes the update not to actually update. It's like if failure flag was once set and the update doesn't try it further.
profile picture

Cone

#25
QUOTE:
opening workspace and failing chart strategy (index out of range exception due to no data) causes the update not to actually update
I couldn't duplicate that with the information provided. I launched WLP with a default workspace containing a single strategy operating on a non-existent symbol in a Fidelity DataSet... generates a Runtime error: index out of range exception. However, this doesn't not affect a Fidelity Provider update in the same session - it runs fine from the Data Manager.

It seems to me that the problem you're experiencing could be this one in our list of Open Issues.
(46123) Fidelity data fails to update again if it was not updated in several months.
profile picture

kazuna

#26
QUOTE:
default workspace containing a single strategy operating on a non-existent symbol in a Fidelity DataSet
My default workspace contains two strategy charts operating on *existent* symbols in a Fidelity DataSet. The automatic update data on demand data update is set to OFF.

Can you duplicate the problem with these settings?


Hmm.Scheduled automated daily update completes without updating any symbols.

This is what I did:
- Rename Default.ws to something else.
- Delete "1 minute" and "Daily" folders under FidelityStaticProvider.
- Launch WLP so that WLP starts without any strategy charts.
- Scheduled automated daily update starts but completes immediately.
- There isn't "1 minute" nor "Daily" folder created under FidelityStaticProvider.

How can I get scheduled automated daily update reload all the symbols?
profile picture

Eugene

#27
After deleting a *StaticProvider folder (of any provider), first try updating its DataSet(s) manually, then restart WLP and retry automated update.
profile picture

kazuna

#28
QUOTE:
After deleting a *StaticProvider folder (of any provider), first try updating its DataSet(s) manually, then restart WLP and retry automated update.
If I manually update DataSet then it works, I know. What I'm trying here is that I delete StaticProvider folder every night and let automated update reload all the symbols in order to prevent this split-update problem. I have many DataSets and it's not realistic for me to update them manually every single night. Why automated update completes without updating if StaticProvider folder is empty (or doesn't exist)?

--------------------------------------------------------------------------------------------------------------

I have deleted not only "1 minute" and "Daily" folders but also FidelityStaticProvider folder completely.
Also I have completely deleted FidelityFMDFundamentalProvider folder.

Then finally scheduled automated daily update completed with reloading all symbols.
Does this make sense to you?
profile picture

Eugene

#29
I'm fine if it works for you.
profile picture

kazuna

#30
Because I got unsuccessful outcomes at many previous attempts, I was wondering if it was just a luck.
I still have to test it more for sure but I'm curious if these results are reflecting the internal implementation.
profile picture

Cone

#31
I also recall this being a problem when the Fidelity provider creates a "0 minute" folder. If you see that folder, close WLP, delete the folder, and try again.
profile picture

kazuna

#32
I have deployed this method (completely deleting FidelityStaticProvider and FidelityFMDFundamentalProvider folders) onto my four paper trading systems and the scheduled automated daily update did complete with reloading all symbols correctly. I have also confirmed this to fix the split-update problem completely.

The only concern is if Fidelity will complain about downloading too many data (several gigabytes in my case) every night.
profile picture

Cone

#33
I can understand the frustration of the bug that isn't updating the data consistently, but there is a solution to it if you can find the underlying cause. '0 minute" folder?

At a minimum, it would be much more efficient to:
1. Create a process to delete the C:\Users\kazuna \AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\FidelityStaticProvider\0 minute folder, if it exists.

2. Then attempt WLP's auto update.

3. Check if #2 failed by inspecting the size of LastUpdateLog.txt, and only if it did fail (size less than say 1kb), kick off your deployment.
profile picture

KGo

#34
I have a this problem. Data update fails after attempting to update a split for 5 min SH. I have read the Wiki Open issues suggestions.

Attempted to reload SH from a chart window but only today's bars appeared. Then clicking stream brought up all data. However, there was no SH symbol in the 5 min Data/S folder even after attempting a reload. SH is listed in the 5 min data set. So why did the wl file disappear?

Closed WLP. Then copied SH data from another computer to the 5 min DataSet. Now opening a static chart window displays all SH history including today's data. The symbol date and time were properly updated as seen in Windows Explorer.

Automatic update will happen tomorrow morning so will see if this fixes it. Any other suggestions are appreciated.
profile picture

Eugene

#35
During your experiments you could've put the WL into where the WLF should be (or vice versa), for example. This could explain the mysterious disappearing of data.

If "Update All Data" still does not work then it's quite unlikely that automatic update should fix it. In this case I'd follow the Wiki suggestions and delete not just SH but everything as more symbols could be affected by recent reverse splits. Otherwise I'm not sure what the problem is now.
profile picture

KGo

#36
Success! Update all data is now working.

The fix was to paste a working SH.wl file into the 5 min folder that was causing the update to abort while attempting a reverse split. The folder had no SH.wl. That single paste was the only action taken outside the standard WLP user interface. No other experiments were conducted beyond an unsuccessful standard data reload from a chart as described in #34 above.
profile picture

Cone

#37
That sure looks like a (the?) smoking gun. I hadn't update my Fidelity data for several weeks until now - the Provider update stopped at the AA 1:3 reverse split, and thereafter immediately stopped there until I deleted it's WL file.

CODE:
Please log in to see this code.


Thanks for the report!
profile picture

Eugene

#38
Robert, this is a long-standing issue. Most of the users affected by the reverse split issue seem to update their data in a regular fashion. It's a different bug:

(46123) Fidelity data fails to update again if it was not updated in several months.
profile picture

Cone

#39
That's why I said "smoking gun". I don't believe that "not updating for several months" is the actual cause of the problem. It could be that the bug always had something to do with updating data with a split in the middle of the series, i.e., ex-date after the last update, but days before the current one.

However, when the data file involving a split is the problem, that message always appears before "Update Completed", consequently, I think it's just another symptom of the same problem, which may have multiple causes.

--- update ---
I just removed that file, and now my update is ending immediately after the 1-minute symbols update without the Processing 1:3 Stock Split for AA message. I updated Fidelity data last week, but now I'm experiencing the 46123 problem.
profile picture

KGo

#40
For background, my data is rigorously updated every morning. Symbols that are used in evening analysis are updated when those strategies are run. SH is in both daily and intraday data. So "not updating for several months" was not a cause. I suspect WL deleted the SH file and was unable to reload it.

I cannot be sure of the SH usage around the split but daily SH may have been updated by a strategy shortly after market close while intraday SH waited for the morning update. A second computer which updated all in AM without issue did not do the after market close daily SH update via strategy. Just a thought... as all is well now.


profile picture

pscanlon1

#41
Im having the same issue here still. Any fix in the works?? Just stops after the first symbol it encounters with a split.

Updating DataSet All Symbols 15min ...
Symbols already up to date: A,AAAP,AAC,AAL,AAMC,AAN,AAON,AAP,AAPL,AAT,AAU,AAV,AAWW,AB,ABAX,ABBV,ABC,ABT,ABX,ACN,ADBE,ADI,ADM,ADP,ADS,ADSK
,AEE,AEP,AES,AET,AFL,AGN,AIG,AIV,AIZ,AKAM,ALL,ALLE,ALXN,AMAT,AMBA,AME,AMG,AMGN,AMP,AMT,AMTD,AMZN,AN,ANTM,AON,A
PA,APC,APD,APH,APO,ASML,ATI,ATVI,AVB,AVGO,AVY,AXP,AZO,BA,BABA,BAC,BAX,BBBY,BBT,BBY,BCR,BDX,BEN,BHI,BIDU,BMRN,CTRP
,DISCA,EXPE,FB,GILD,INTC,MYL,NTAP,PFE,REGN,TSCO
Processing 1:2 Stock Split for BIIB ...
Update completed (3.196 sec)
----------------

profile picture

Eugene

#42
A reverse split (not just a split). However, there's something that I have trouble explaining in this log...
QUOTE:
Processing 1:2 Stock Split for BIIB ...

...considering that BIIB hasn't split even once:

https://www.splithistory.com/biib/

P.S. As for a fix, I think Fidelity knows their schedule better than we do. Sorry, no information.
profile picture

KGo

#43
BIIB spun off BIVV and is paying BIIB shareholders of record on 1/17/2017 a one share dividend of BIVV for every 2 shares of BIBB owned and held through the distribution date of 2/1/2017. It amounts to about a 8% dividend.

Fidelity sometimes adjusts prices for large dividends via a stock split. On Fidelity ATP a 1:2 split is noted incorrectly but prices were adjusted about 8.5% to correctly account for the distribution. In WLP deleting the symbol and reloading and prices will likely match ATP.

BTW Yahoo shows unadjusted prices and MSN shows adjusted prices like Fidelity ATP.

I suspect WLP would have done a 1:2 split if not for the known issue. The older WL4 did the 1:2 split and prices needed to be corrected.

profile picture

Cone

#44
PROBLEM:
Fidelity Provider updates terminate prematurely when processing a split.

SOLUTION:
Delete the symbol from all timeframes and repeat the update.

Here's a script that will help with that solution.

1. Save the script below.
2. Click the symbol that you want to delete in any of the [Fidelity] Provider's DataSets
3. Click "Yes" to confirm you want to delete the data.
4. Re-run the Provider update.

CODE:
Please log in to see this code.
profile picture

Eugene

#45
Solution added to the Wiki. Thanks Robert.
profile picture

KGo

#46
Especially nice code since it simultaneously deletes the symbol data from all Fidelity data sources and bar scales. Thanks.