WL 6.9 takes forever to start
Author: MrIzzy
Creation Date: 11/20/2015 5:11 PM
profile picture

MrIzzy

#1
WealthLab 6.9.12.0 on Windows 10 system.

Takes more than 5 minutes to start.

Any idea why?
profile picture

Eugene

#2
You need to give us many details first if you want us to have ideas. We don't know what your system is exactly, what programs do you run, which modules are loaded, how many strategies do you have, and more importantly what exactly did you do to make this happen. Does WLP run normally after startup? Does it throw any messages while loading (for example, a dialog box is shown when a corrupt strategy file is found or you've changed regional settings)?

1. Make sure antivirus or other security software isn't affecting WL.
2. Try loading without any strategy files in AppData/Roaming/...
3. Temporarily move out any extension files and especially custom-built DLLs (if any) you may have.
4. Reinstall Wealth-Lab Pro.
5. Try reinstalling .NET Framework 4.5 or above.
profile picture

Cone

#3
6. In C:\Users\[you]\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\Workspaces, rename Default.ws to Default(old).ws so that a potentially "busy" workspace is not loaded when starting.

7. Using the Extension Manager, uninstall extensions that you will not use. More extensions, more scripts, more loading time.

8. If you have scripts on a Network drive, make sure the connection is functioning.

etc., etc.,
profile picture

MrIzzy

#4
It is a fresh WIndows10 Home computer. There are no additional features loaded into WL. I just downloaded WL (from the link in Fidelity Active Trader Pro) as is and it takes forever to load. The PC says it already has the .NET framework as part of the O/S.

profile picture

Eugene

#5
Okay, then you can scratch #3 and #7 off the list of troubleshooting suggestions.
profile picture

MrIzzy

#6
1) I use AVG Internet Security
2) Tried
3) I don't have any
4) Reinstalled
5) Not applicable
6) It doesn't have a Default.ws file
7) No extensions as it is a new install
8) No scripts


I really don't know how to proceed
profile picture

Eugene

#7
5) If so, then this is here out of thin air since 2008: Wealth-Lab 5/6 is unusually slow:

"Starting WL5/6 may take minutes..."
profile picture

MrIzzy

#8
I think something is seriously wrong with my installation.
The daily chart of AAPL shows just fine but the daily chart of KRFT shows "no data available"
profile picture

MrIzzy

#9
See here
profile picture

Eugene

#10
I don't believe this is connected. If "on demand data update" is disabled in the Data Manager (recommended), symbols which aren't up to date would show this innocuous message until you update the DataSet.

Since I've got no feedback on my suggestion I'll give you one more reason #9 and stop here: Firewall. If Extension Manager is set to check for updates on startup, your firewall or antivirus may be blocking attempts of WealthLabPro.exe to initiate the connection. Given that it's a fresh installation I doubt it's very likely, though.

Ultimately, #1 and #9 are connected. You should make sure that neither AVG nor any other firewall or security tool is getting in the way.
profile picture

MrIzzy

#11
I think everything is resolved.

I reinitialized the computer and then downloaded WealthLab on a "clean" computer. It starts in a reasonable amount of time.

Thanks
profile picture

Eugene

#12
#9 One more suggestion to others who may encounter the same issue: try creating a brand new Windows account and install WL in there. If it's still slow to start up, then focus on reinstalling .NET and disabling antivirus/firewall.

Glad you've got it sorted out. So #10 is: Reinstall Windows from factory image.