WL 6.9 Workspace: chart beyond certain bounds
Author: richard1000
Creation Date: 10/29/2015 11:23 AM
profile picture

richard1000

#1
It appears WLP 6.9 (64-bit) has workspace size limitation. If I save a workspace with a chart beyond certain bounds, and reopen the saved workspace, all the charts collapse into x,y (0, 0) location.

WLP 6.8 did not have this problem.

I have attached a copy of saved workspace to show what I mean.
profile picture

richard1000

#2
I had to save the .ws into .txt to upload the attachment.
profile picture

Eugene

#3
QUOTE:
Bounds=4252,4,490,470


HXGA is 4096x3072. What is your resolution then?
profile picture

richard1000

#4
I using six monitor of Samsung 204B with native resolution of 1600 x 1200 at 60 Hz.
profile picture

Eugene

#5
Sorry, at the moment I don't have a multi-monitor configuration to verify the issue.
profile picture

richard1000

#6
Even with a single monitor, you should be able to open the workspace and move the scroll to view the opened charts. For example, see attachment.

So, if you change the parameter for my monitor (other monitors may need different parameters) from Bounds=3000,10,547,479 to Bounds=4000,10,547,479, the charts collapse to a single location.

My request is to roll back the saved workspace size to be same as WL 6.8.
profile picture

Eugene

#7
QUOTE:
My request is to roll back the saved workspace size to be same as WL 6.8.

It's not that simple. This may be by design because there is some multi-monitor fix in v6.9. Cone, by chance you have the information?
profile picture

Eugene

#8
Richard,

Have you recreated the previously saved workspace in 6.9? What was the outcome?
profile picture

Eugene

#9
Richard,

Please try updating to 6.9.12. Sounds like there was some fix to multi-monitor issues:

WL 6.9: Multiple windows not aligning properly after reopening workspace
profile picture

richard1000

#10
So I just upgraded to 6.9.15 and this problem has returned again. What is going on here???
profile picture

JDardon

#11
I just upgraded to 6.9.15 and now a workspace that I had created before with 7 windows layed out side by side horizontally just opens up all the windows (same size as in the saved workspace, but all on top of each other at (0,0).

I tried saving the workspace as a new name and then reopening it and didn't work. Only some of the windows came up in their proper place and the rest were layed out on top of each other at 0,0

Figuring out that maybe a second time would fix some more I tried saving ait a second time to a new name and then it worked.

Apparently there is something corrupted that carries on to the first save but is completely eliminated with the 2nd save.

I did this for 3 different workspaces and in all of them the 2nd save to a different name solved it.
profile picture

ivraju

#12
I saved 4 times, haven't solved my other problem.
profile picture

JDardon

#13
It seems whenever I save an replace an existing workspace the windows get messed up. I have to save to a new name and then (outside of Wealth lab) delete the old one and rename the new one.
profile picture

Eugene

#14
Thanks Jorge, added your workaround to Open Issues.

QUOTE:
then (outside of Wealth lab) delete the old one and rename the new one.

Why outside? The "Open" dialog lets one to delete (right-click) or rename a file (F2 key).
profile picture

JDardon

#15
QUOTE:
Why outside? The "Open" dialog lets one to delete (right-click) or rename a file (F2 key).


I know, I just was distrustful of what was going on so I wanted to make sure that Wealth Lab would not be aware of the change. It probably works just the same if you do it within the dialog.
profile picture

richard1000

#16
I assume this problem will be fixed on next WL release. So when is the next release?
profile picture

Eugene

#17
I would not make assumptions like that. Please see post #13 on what you can do now to convert your existing workspaces if they're affected. Newly saved workspaces should be issue free.
profile picture

richard1000

#18
I tried #13 before but it did not work and I tried it again now and it does not work. I tried saving to new names and the results were the same. The workspace windows were top of one another at (0,0).