Strategy window settings don't stay as I set them
Author: sourkraut
Creation Date: 2/16/2012 1:36 PM
profile picture

sourkraut

#1
I open a strategy and maximize its window. Fine so far.
But when I switch to a different strategy, both (or all) open strategy windows revert to UNmaximized.

I consider this a bug in WL.

A well-behaved program's settings ought to remain unchanged until the user changes the settings.

TIA

Eb
profile picture

Eugene

#2
What does it mean, I switch to a different strategy? So far you opened and maximized one window. Anyway if there is another strategy window in the background, its settings are preserved for me: switching between the two keeps them maximized.

Maybe there's some multi-monitor specific behind though. Try describing your setup and action sequence in a greater detail.
profile picture

sourkraut

#3
QUOTE:
What does it mean, I switch to a different strategy?


Change, to one of

CODE:
Please log in to see this code.


Any of these methods open a less than maximized strategy window, even if they were maximized the last time I used them.

WL Version 6.2.46, 64 bit, on a 2-monitor system.

YES, I get upgrade notices, but the download ends in an error message, and gives me telephone number to call. It's 5AM, and I don't suppose any one is manning that phone.
profile picture

Eugene

#4
While I don't believe this is more than a very petite annoyance, there must be something else to it because I have not been able to catch it. Any of the actions mentioned result in an expected outcome: cycling through open strategy windows will preserve their maximized state - either in maximized or normal workspace, in main or secondary workspace etc.
profile picture

sourkraut

#5
On the one hand I can't help but admire the enormous work you guys produce in these Forums, responding to user requests. On the other hand, there are a lot of issues you just dismiss as trivial, or as having a lesser priority that the next big feature to be added.

Has it ever ocurred to anyone, that you're buildig these new features on a bug-ridden white elephant that will make these new features just as bug ridden, as the old ones? And that sooner or later this entire house of cards is going to come crashing down?

A year and a half ago, I got tired of banging my head agains the wall and just stopped using WL.

Now I have once again have some ideas, I'd like to try out, wihtout moving to another broker and learning yet another backtesting language.
It didn't take long before I ran into the same old wall. The same old irritations from years ago. The same crashes as years ago.
So I'm opening these old issues, if they are still present, to collect one big complaint to Fidelity.

QUOTE:
While I don't believe this is more than a very petite annoyance,

Actually, in the frame of all the other annoyances, this loomed rather large in February 2012, and continues to do so 19 months later!
It's a constant reminder of the many other irritations and unfixed bugs in WealthLab.
A side effect of the unmaximized windo is, that the title of the strategy is often invisible, because it shows up in the WL title bar only when maximized, and the strategy title bar is voered when WL opens.

QUOTE:
there must be something else to it because I have not been able to catch it. Any of the actions mentioned result in an expected outcome: cycling through open strategy windows will preserve their maximized state - either in maximized or normal workspace, in main or secondary workspace etc.

The only way I can cycle through strategies, and find the next window still maximized, is to use CTRL+TAB. This does not work when opening a strategy from disk. They always open at less than full size.

Just another part of the inept windows management in WealthLab.

It gets worse, when I open the Data Manager. It not only never comes up full size. I opens scrolled DOWN, so if I want to maximize it, I must first scroll up to uncover the maximize button. Trivial? I don't think so.
profile picture

Eugene

#6
Thank you for your appreciation of our work.

19 months later I'm still unable to reproduce this "bug", but in those 19 months, other users never stop asking for new features and coming with reproducible bugs. This other camp feels just the same as you, just for different reasons - like absense of WFO optimization, or optimizer not utilizing modern-day multi-core CPUs, or an old bug staying deferred etc.

It's normal that sometimes users like you have issues that either can not be reproduced by our team, or intermittent bugs that strike twice a year. Bugs are being fixed in each new release - with regard to their severity (critical ones first), or those without known workaround(s), and/or those affecting (much) more than just a single user. I wish we could please everyone, but our resources are limited. That's how it goes in this business.
profile picture

kribel

#7
Hi sourkraut,

I cannot reproduce this behaviour, at least not everything. However I do experience some of it.

QUOTE:
It gets worse, when I open the Data Manager. It not only never comes up full size. I opens scrolled DOWN, so if I want to maximize it, I must first scroll up to uncover the maximize button. Trivial? I don't think so.

I do experience this issue as well.

The problem is, that WealthLab saves the window settings, the size of the windows and their position with absolute coordinates instead of using relative coordinates. You can see it by simply opening your configuration of the default workspace. You can find it here:
CODE:
Please log in to see this code.


There you will find someting like this:
CODE:
Please log in to see this code.


As you can see the Bounds values specify the absolute coordinates of the DataManagerForm. This becomes a problem, when you set the default workspace using a display with one resolution and using it with a display with a different resolution. Deleting the Default.ws file helps a lot. Deleting it might also resolve your other issue with maximised windows.

Once I maximise one window within WealthLab, then all other windows open maximised.

QUOTE:
The only way I can cycle through strategies, and find the next window still maximized, is to use CTRL+TAB. This does not work when opening a strategy from disk. They always open at less than full size.

There is another way. Go to the Window menue and choose your desired window. Of course it would be much more elegant if WealthLab would provide some fancy tabs for all open windows just like any modern internet browser.

Cheers
Konstantin

profile picture

sourkraut

#8
Thanks for your suggestions, Konstantin.

Ironically, saving the absolute positions in the default strategy should help, rather than hinder, because I always run WL maximized.
When I SAVE a new default strategy, I do so while maximized.

Still, WL restarts in "normal" mode, rather than mximized. Though the window actually opens LARGER than my monitor size, overlapping into the adjoining monitor. Then I maximize, to shrink it back to full screen.


The bounds values in my default.ws file are inconclusive, since my default ws contains two charts, tiled horizontally (in other words, normal mode).

Eb
profile picture

sourkraut

#9
Eugene,

QUOTE:
19 months later I'm still unable to reproduce this "bug"

That's funny.
It took me a SINGLE TRY to duplicate these problems on another WL installation, completely different hardware. Different OS (W7 Home Premium vs W7 Utlimate) , different screen resolution (1600*900 single vs 1920*1080 dual monitors).

Both installation show exactly the same UNORTHODOX windows management, opening the app window to LARGER than screen size. When I maximize the window, the title ("Fidelity Wealth-Lab Pro 6.5...")) actully jumps DOWN, on both monitors.
The default chart is not maximized, as it was before closing. I had to scroll UP and To the RIGHT to reach the [X] to close the window.
Maximizing the chart, then opening a second strategy, maximizing it, and then returning to the first chart, the first chart was no longer maximized.

I do not know how you could possibly NOT duplicate this, if you use the same distribution, that Fidelity has on their website for download.

CC: FIdelity Support
profile picture

kribel

#10
Hi sourcrout,

QUOTE:
Still, WL restarts in "normal" mode, rather than mximized.


You can change this behaviour by executing the following steps:

1. Go to WealthLab starter properties



2. Change the Run option in the properties to maximized


Now WealthLab shoud start maximized.

@Eugene:
Is there a user guide on how to use the syntax of this forum. I cannot embed attached screenshots into my text. However, I am sure this is possible.
profile picture

Eugene

#11
QUOTE:
I cannot embed attached screenshots into my text. However, I am sure this is possible.

Konstantin,

After making a post, copy and paste the image attachment link in between a pair of IMG tags. For that, click the Image button. I've edited your post to display inline images.

QUOTE:
I do not know how you could possibly NOT duplicate this, if you use the same distribution, that Fidelity has on their website for download.

Eb,

There are many graphic drivers out there, with numerous settings, and who knows how many 3rd party utilities standing in the way (virtual desktops, graphic chip tuning, other added features). If it works like it does on your configuration, doesn't mean that the whole wide world is experiencing the same.
profile picture

sourkraut

#12
Hi Konstantin,

Some 3 1/2 years ago I got so P.O.d at Wealth Lab, that I didn't use it for so long.

I did not mean to be rude. I just didn't see your last post on this topic.

Just as an aside, what brought me back is WL's data storage, letting it run offline without a data feed.

I tried your suggestion, and it worked in using a fixed maximum application window (thank you very much).
Sadly, this did not fix the other screen management problems. I still must move them around to get at the
maximize button.



Regards,

Eb.