Some fundamental data showing zero when plotted
Author: cheers32
Creation Date: 4/30/2017 6:28 PM
profile picture

cheers32

#1
Hi,

I just realized my fundamental data are not available. In fact, except the Fidelity equity summary score and category, all fundamental data from all providers I tried does not show a value. I have upgraded the WealthLab to the latest version, as well as all extensions. I tried both logging in to Fidelity and not logging in, but none worked. I was also hoping MS123 extension to work, but I had the same issue.

I tried to search for this issue on the forum but also didn't find an answer.

I attached a screenshot. Could you help to find out where I need to change to have the fundamental indicators to work?

Thank you,
Wei
profile picture

Eugene

#2
Hi,

Before using any fundamental data, it must be updated. On the Data Manager's Update Data tab, check all applicable providers and run "Update All Data" first. Then reload the chart (or Strategy) window.

Re: [yc] I30:YTR. YCharts Economic data is available to paid subscribers only. Unless you're a YCharts customer this item will be empty.

Furthermore, specific to non-symbol fundamental items like YCharts Economic, drag and drop doesn't function for them. This is known bug 182124. Workaround: click "Push all indicators and fundamental items into the Strategy code".

Re: Google / Reuters news. These items are to be enabled from the Preferences dialog > Chart Annotations. They aren't that useful if plotted via drag and drop.
profile picture

cheers32

#3
Thank you Eugene. This works now.
profile picture

Eugene

#4
You're welcome.