Snapshots tab always empty
Author: murty
Creation Date: 7/3/2016 11:23 PM
profile picture

murty

#1
I have Perf Visualizers addin installed. I can see Snapshots tab, but its always empty. Even when I hit Cntrl-S

I get no errors, see no errors in logs and nothing in debug console.

I like ReportLab which saves code as well as strategy performance results. Does ReportLab work with WLP 6.x ?
profile picture

Eugene

#2
I'm not sure what do you mean by saying "even when" because Ctrl-S is the only way to get the ball rolling. Let's see what the Snapshots user guide suggests re: its limitations:

* Code is saved only for code- and rule-based strategies; Combination strategies and compiled Strategy libraries are not supported.
* Snapshots may not get saved if Strategy with identic Guid exists under different names. This can only happen after manual cloning of XML files outside WLP.
* If you haven't made any changes to the code, subsequent snapshots will not get saved.

So if you open the built-in "Moving Average Crossover" strategy, strike Ctrl-S and the tab won't populate I'm going to need as much additional evidence re: your software environment as possible. Let's start with WLP version and bitness, .NET version (can be seen in Control Panel > Programs or other ways to check it) etc. Then, please navigate to this folder after enabling hidden file/folder visibility and tell me what files do you see there in the root folder (don't open any subfolders):

c:\Users\Windows username\AppData\Roaming\Fidelity Investments\WealthLabPro\1.0.0.0\Data\Strategies\

P.S. It's pleasing to me as a co-founder of Alnissoft (the team that made Reports-Lab) that you still like the software but it cannot be used with WL6.