RSI Rotation Strategy placing market orders as GTC
Author: Tobey
Creation Date: 7/6/2011 10:53 AM
profile picture

Tobey

#1
Hi Cone & Eugene,

I'm running the RSI rotation strategy on weekly data in the Strategy Monitor.
Then I'm Monitoring it in the Quotes Window and using Place Orders to activate the order.
In the Orders Window it generates an error, the TIF column is reading GTC.

What do I need to do to set Market orders to day?

CODE:
Please log in to see this code.
profile picture

Eugene

#2
Alerts by Strategies using Weekly and larger scales are placed as Good Til Canceled (GTC).

profile picture

Cone

#3
When strategies are run on higher than a Daily scale, the trades should be entered GTC at the start of the period.

1. These are market orders. Why would you use the Quotes tool, which will trigger the order immediately anyway?

2. What is the error, precisely? If it's an order entry error, click on it to see the text.
profile picture

Tobey

#4
Hi Cone & Eugene,

Cone you are right that the orders just automatically trip in the quotes window when the market opens.

I've been using the Strategy Monitor to run a couple of strategies for a couple of portfolios. Then I pick them all up in a Quotes Window. A lot of then are Limit Orders. The market orders I usually place just after the open, once I get a sense that there aren't any big surprises at the opening.

Here is the error message:

0: Error(s): The Time in Force selected for this Market order is invalid. Valid selections for market equity orders are Day, On the Open, and On the Close. For market option orders, only Day is permitted. Please review your order.

Now that I understand what is going on, I can stage the orders and use the Edit Order box to switch TIF: from blank to Day.
Or maybe there is a way to change the code to do something like a limit order 4% or 8% above the close. Something like that shouldn't effect the results and would save a few steps.

Thanks again for your help,
Tobey
profile picture

Cone

#5
1. Thanks, if there are limit orders involved, I understand :)

2. Goodness, how embarassing not to have noticed this one before! The right way to go for now would be to modify the order. Fidelity will reject limit or stop orders whose trigger prices would result in an immediate fill.

Thanks for spotting the problem with GTC/Market. We'll put that one in the queue for fixing. At your convenience, please create a Support Ticket for that to make sure I don't forget about it.