Odd auto-trading results in Account Balances
Author: zanek
Creation Date: 6/26/2009 9:46 PM
profile picture

zanek

#1
I'm been autotrading with a paper account in WL 5.3, and I'm about to go live with autotrading on my real account, but I'm kinda worried, because the paper trading results are dont reflect the results I get while backtesting for the same day with the same stock.

Sometimes there is a 'Sell' order in the "Orders" window and its marked Active for like 10 seconds, then the "status" changes to "Canceled". I presume this is causing the Account Balances page issue below. I cant figure out why this is happening , any ideas ?

The paper trades are close to the same time, but the Accounts window's "Positions Value" amount isnt updating with the correct amount while paper trading, and the 'Account Value' at the bottom of the window almost never updates. It still lists the original amount from when I created the paper account (I click 'Update' and nothing happens). When I look at the "Local Trade History" and tally up the trades, I should have actually made more than what the Accounts window is showing that I made for the day.

Does anyone know if this is normal for autotrading paper accounts ?

I'm just worried that if I switch to live trading, that something could go wrong and I wont really be able to tell because of these problems. Hopefully the problems are just with paper trading account.

I have the strategy setup to autotrade from a strategy in the 'Strategy Monitor' and it generates the trade signals in the orders page
profile picture

Cone

#2
See the User Guide for the limitations of Paper Trading. It's simulated, doesn't use the broker's "backend", and if you don't use Market orders, it´s prone to become out-of-synch with the Strategy's trades.
profile picture

zanek

#3
Ahh, thanks Cone ! I just read that section in the user guide and you are correct ! Thats definitely good to know.