No Alerts in Strategy Monitor with 3rd party SmartTrade provider
Author: iliakan
Creation Date: 7/9/2009 9:56 AM
profile picture

iliakan

#1
Hi,

I'm using WL Dev 5.1 and managed to run Strategy Monitor.
The problem is:
alerts are shown on particular strategy window if I view it separately
But
alerts are not shown on strategy monitor

All strategies are Activated and Running.
I tried to enable AutoStage too.
profile picture

Eugene

#2
Which data provider?
By alerts for a particular strategy, do you mean actual alerts shown on the Alerts tab or historical positions?
What about the "Show alerts for all strategies" button?
profile picture

Cone

#3
Most likely causes:
1. the settings or data are different, or,
2. you didn't click on the Strategy to see its alerts, or,
3. you didn't click on the "Show Alerts for All Strategies" button in the Alerts pane toolbar, or,
4. the Strategy is scheduled to execute, but has not yet.
profile picture

iliakan

#4
The alerts are shown in Alerts tab of particular strategy. I mean alerts tab, not chart.

The data provider is SmartTrade (extension from my broker).
I clicked on "show alerts for all strategies"
The strategy is red and running..

profile picture

Cone

#5
If the Strategy is red in the Monitor, then it is still trying to update and/or execute the Strategy. What color does it turn after being red?

What version (Pro or Dev) and build are you using?
profile picture

iliakan

#6
I'm using 5.1 Dev, it is red and status shows it's waiting for update.
Not sure if it is normal or not..

Same strategy in standalone window just executes with alerts.
profile picture

iliakan

#7
It is waiting for update N, where N is number of symbols in dataset which I fed to strategy.
profile picture

Cone

#8
It sounds like the provider is not providing the data.
profile picture

Eugene

#9
In other words, your data vendor didn't implement the support for Strategy Monitor in their library.