New optimizer: Exhaustive to Local Maximum Optimizer
Author: Eugene
Creation Date: 12/31/2016 2:59 PM
profile picture

Eugene

#1
We're proud to present a new and very fast optimizer created by community member Kurt Meister.

* Direct download link
* Online user guide (Wiki)
profile picture

Eugene

#2
I've already tried it out and it's blazing fast. Thanks for the holiday gift, Kurt!

A couple of suggestion for future consideration might be:

1. Minor cosmetic suggestion. Instead of using TextBoxes (which allow editing) on the Optimizer Performance tab you might want to use Labels instead.

2. Auto-sense the list of parameters from selected Scorecard. Currently the list is being re-populated after reloading the strategy window but LenMoz has found a clever way to do it on-the-fly (which may be complex I believe).
profile picture

LenMoz

#3
For me, the custom tab, "Optimizer Performance", never seems to change. See attached .png. Yes," Runs for Exhaustive Optimization" may seem excessive, but PSO works with the associated parameter definition.

And thanks for mentioning me in the Local Maximum Optimizer Wiki credits.
Len
profile picture

Panache

#4
Without knowing more about how many Parameters you are optimizing, it's hard to say what's happening.

My guess is that you are finding a local optimum relatively close to your Start values. In the Results tab, the results of each run are printed sequentially, so if you look at the metric you're optimizing, it should peak and there should be 5 (assuming you are using the default Number of Steps after Highest Value) more steps with each Parameter, none of which result in a higher value for your metric.

If you can post a screenshot of the Results tab, that would be helpful.

QUOTE:
Runs for Exhaustive Optimization" may seem excessive

I don't think that's the issue. I haven't tried it with a trillion, but I have been running it on a hundred million.
profile picture

LenMoz

#5
This time the Optimizer Performance tab is not populated at all.

Optimization Control showing parameters image is attached.
profile picture

Panache

#6
QUOTE:
the Optimizer Performance tab is not populated

It won't populate until the optimizer is finished. You can click Cancel Optimization and it will populate.

Also, I'm obviously sleeping today. I meant to have you look at the Results tab, NOT the Optimization Control tab.
profile picture

JDardon

#7
Thanks for the contribution Kurt. I am just trying it out.

How are you calculating the estimated number of rounds and the estimated time?

Your worse case scenario would be a full optimization in the case that the optimal is located near the maximum values but the best case scenario is a local optimal close to the start values.

profile picture

Panache

#8
QUOTE:
How are you calculating the estimated number of rounds

You are absolutely correct that there is no way to estimate the number of runs. The "Runs Required:" is the lesser of the number of runs for an exhaustive optimization or 10,000. 10,000 was chosen because at 10,001, Wealth-Lab will generate a message box saying this optimization requires a large number of runs, and I didn't want to have to click through that every time I ran this optimizer. The advantage of using the number of runs for an exhaustive optimization or a relatively large number is that the progress bar continues to be meaningful.
profile picture

richard1000

#9
I am getting an error before I can try this optimizer. I chose "Abacus" as optimization method and the error is

Method not found: 'Boolean WealthLab.StrategyParameter.get_IsEnabled()'

I am using WLPro 6.9 64-bit.
profile picture

Eugene

#10
This is an odd error. I positively cannot imagine it happening in version 6.9 only since IsEnabled (that supports Enable/Disable Optimization Parameters) was added in 6.9. Only if you're running 6.8 or lower.

1. Which WLP build is this (6.9.12, 15, 16)? See Help > About.
2. Could you attach a full-size screenshot showing Optimization Control and v6.9 in the app title?
profile picture

richard1000

#11
I am using WLP 6.9.12.
profile picture

Eugene

#12
Like I suspected, selectable Optimizer parameters (the checkboxes that enable/disable optimization parameters) are not supported by your build. Hence the error message from the optimizer that doesn't expect it. To use this optimizer you have to upgrade to a later build (6.9.16).