IQFeed plotting new bar issue
Author: bishop
Creation Date: 3/12/2012 6:49 AM
profile picture

bishop

#1
Hello,

I have a problem with plotting a new bar of @ES# after the end of the current period with IQ Feed (1min in my case).

After I press "Stream" with IQ Feed checked in Streaming Data Preferences I can see a new bar on the chart which accumulates data for all 1min periods, but not just for 1min. I mean that after current minute is expired I expect to see a new bar, but that doesn't happen.

How can I make WL to automatically plot a new bar after each period?

Thank you.

P.S.
WL6.3 x64, IQ Feed Client 4.8.1.7, Win7 x64
profile picture

bishop

#2
update:
after I finished writing my previous post and doing nothing in WL I have noticed that new bars were added and now, after each minute the new bars are added on the chart.



Disabling and enabling Stream again repeats the situation described in post #1

Thanks
profile picture

Eugene

#3
How is the symbol defined in the Market Manager?
What time zone you're in?
profile picture

bishop

#4
In Market Manager the symbol is defined as @ES#
My current timezone is GMT+3
profile picture

Eugene

#5
Could you expand on the market's Properties (Holidays, and Special Hours)?
profile picture

bishop

#6
I have created a new Market, named 24/7 and checked IQ Feed data provider.
In Properties I defined Open Time as 0:00:00, Close time as 23:59:59 and checked "Use this Market by default".
Holidays are empty, Special Hours are empty, Symbols @ESH12 and @ES#

profile picture

Eugene

#7
I am able to duplicate the issue. Thanks for the heads-up.
profile picture

bishop

#8
Thank you very much.

Any ideas when to expect the fix? Approx.?
profile picture

Eugene

#9
This is not a bug. What was illustrated in topic starter's first post is merely attributed to having a delayed data subscription.

For +CL# in particular, open up IQFeed Connection Manager and verify that your subscription is realtime, i.e. NYMEX and not DL-NYMEX. The DL- prefix stands for "delayed".