Font sizes and menus look big in Windows 10
Author: drjaymichael
Creation Date: 9/6/2016 12:48 PM
profile picture

drjaymichael

#1
Well, when I first I first installed Wealth Lab Pro in Windows 10 it was unusable. Top menu with 24 point type and data menu (scale, etc.) with 3 point type and windows for price (open, high, low, close) 3 point type and stacked on top of one another so unreadable.

I had somehow solved this and made it readable and look good but unfortunately did not keep notes. I had a problem which made me need to reinstall windows and now I am back to the first problem as described above.

One would think that someone would have kept notes on how to solve this issue since it would appear to affect every single user of windows, the current operating system. One would also have thought the developers of WLP would actually fix this problem so the program comes up correctly in windows 10.

So. . . I am hear asking. Does someone know as series of commands with windows 10 font resizing etc to get WLP functioning and looking properly?

Michael
profile picture

Eugene

#2
Hi Michael,

Although there are several workarounds that work for some (see Open Issues in the Wiki), in your case the issue was solved only by setting "Disable display scaling on high DPI settings" checkbox. To do it, right click on Wealth-Lab's task bar icon, then again to invoke "Properties" and there is a checkbox on the Compatibility tab. Here's a guided tour:

How to Make the Windows Desktop Work Well on High-DPI Displays and Fix Blurry Fonts
profile picture

drjaymichael

#3
Hi. Thanks for the reply. Well, this is great. Thanks very much. Yes, this is up and looking good with a couple of exceptions.

So a couple of other questions.

First, the dataset box must be pulled way over so that it takes up almost a 1/4 of the screen. Is there some way to make this smaller?

Second, when I go to login with Fidelity a scrunched up box comes up where all the options to enter the id and pw and do OK are not on the small screen. What to do about this?

Third, the button on the bottom right that is typically there so you can sign in for daily updates is not showing up. Maybe that's because I have not been able to log in.

Fourth, I was only able to get to properties because a shortcut screen was on the desktop since I reinstalled today. When I find the program in programs/fidelity/wealth lab the properties folder that opens does not include compatibility as an option screen. If I search the hard drive and get a list of Wealth lab pro files I was able to open a properties menu that provided the compatibility option. But it seems this ought to be easy to access.

Thanks again for the help. If you can help me tweak per above this would be much appreciated.

Michael
profile picture

Eugene

#4
Try reverting to the standard "Smaller - 100%" text size in Windows Control Panel > Display applet.
profile picture

drjaymichael

#5
That helped. However, 100% is way too small. Everything on the screen comes up about 6 point type. 175% seems to be a good compromise. The login window is a bit scrunched but usable. The button on the right for updates is still not there, however. But all looks pretty good and is usable. Thanks again. Very good to know.

Other comments about how to easily get to the properties window?

Thanks.

Michael
profile picture

Eugene

#6
Glad to have helped.

Re: 100%. Indeed it may look small when chosen monitor/laptop is inappropriate for text related works. Here's a guide on dot pitch but I'm sure you can find more resources which help determine whether the device would have the font size comfortable for the eyes or not. High resolutions like FullHD on a typical laptop (15") or a 20" display will make the text uncomfortably small for most eyes. As a rule of thumb, anything below .28mm - .29mm is a recipe for eye fatigue and should be avoided for anything but watching movies or playing games. That's just my HO but it has worked well for years.

Re: Properties. As I didn't reply this means I have little to no to comment on that. I cannot reproduce what you're saying. If it's not there you were clicking the wrong icon e.g. a DLL, XML file of the same name or even a broken shortcut. The illustrated guide link in my reply #2 shows how to get the Properties tab in Windows. Like I said in Windows 10 you have to make two right-clicks on the app's icon in the task bar to get there. With desktop shortcuts or the EXE file itself it's simpler.
profile picture

bentonjj

#7
I run Windows with the display set to 125% scaling (and will probably increase when I get older) which was causing some text in WLP (position size text boxes, status bar, etc) to have oversized text. Changing the "disable display scaling on high DPI" on the Compatibility tab looks like it corrects this.
profile picture

rbryant

#8
"Disable display scaling on high DPI settings" checkbox worked perfectly. Thanks Eugene.