Fail to create a new DataSet via Excel Provider after migration to a new computer (64Bit)
Author: lookingbackon
Creation Date: 12/26/2012 9:33 PM
profile picture

lookingbackon

#1
Hello,
I just finished the migration of previous WLD6.2(32Bit) to a new computer with WLD6.4(64Bit)and fail to create new DataSet via Excel Provider. The error report showed when I try to select XLS file for dataset creation:

Error: The ConnectionString property has not been initialized

Could you help to detect what would be the problem with that?
Thanks
profile picture

Eugene

#2
Excel static provider > "Note to Wealth-Lab 64-bit edition users"
profile picture

Eugene

#3
P.S. The Wiki link should be sufficient to solve the problem.

However, if it happens that you must run 32-bit MS Office on your 64-bit Windows, consider reviewing this discussion too:

Excel Static provider error message

Basically, it says that if you run 32-bit MS Office on a 64-bit PC, making the Excel provider work can be made either by installing 64-bit Office or by installing 32-bit WLD.
profile picture

lookingbackon

#4
Thanks for the guide. The issue is now clear. It seems like I have to install 32-bit WLD to replace the existing 64-bit WLD.
BTW, is there any particular operation needed to replace the installed 64-bit WLD?
Thanks
profile picture

Eugene

#5
QUOTE:
It seems like I have to install 32-bit WLD to replace the existing 64-bit WLD.

Not exactly: only if you must continue using 32-bit Office apps. If you can install 64-bit MS Office OR replace them with an alternative (offline: OpenOffice/LibreOffice, online: Google Drive/SkyDrive), then you can install the 64-bit driver and work in 64-bit Wealth-Lab.
QUOTE:
BTW, is there any particular operation needed to replace the installed 64-bit WLD?

No need to replace it. Install it alongside 64-bit Wealth-Lab to work with the Excel provider in 32-bit WL, and enjoy benefits of 64-bit WL for everything else.
profile picture

lookingbackon

#6
Got it. Thanks