Errors in updating with Extension Manager
Author: sourkraut
Creation Date: 1/21/2011 3:45 PM
profile picture

sourkraut

#1
I've had several attempts at this. Same results.

When I upgraded WL I provided an Admin password, and the upgrade went OK.
When trying to upgrade a library, if it involves writing to the WL program directory, I get access denied errors.


1. Updated WealthLab.Indicators.Community using Extension Mgr
a. the Update Now button resulted in request for
Administrator password, provided.
b. but the upgrade somehow lost the elevated rights in the
process of upgrading, resulting in the following:

2. Restart WealthLab, error:
a. Wealth-Lab Pro has stopped working
b. Scheduled actions (grayed out, cannot access "Copy to Clipboard" button.
1) Community Indicators library
Failed to connect to an IPC Port: access denied
2) Extra Performance Visualizers (...extra.dll)
(ditto)
3) Extra Performance Visualizers (ZedGraph.dll)
(ditto)
3. Restarting WL succeeded.
a. Extra Perfomance Visualizes 2010.05 marked NotInstalled
b. Community Indicators library 2010.12 shows NewVersion 2011.01
"Update Now", which was what I did in step '1.' above.


Eb
profile picture

Eugene

#2
The IPC port error is a .NET remoting error caused by lack of elevated rights, as you correctly pointed out. Extensions should only be installed and updated with administrator privileges. When updating an extension, try the following:

1. Don't click "Restart WL" immediately.
2. Instead, close it normally.
3. Now start WL with admin privileges explicitly by right-clicking its shortcut and selecting 'Run as admin'.

This way you still can see an error message after confirming the UAC prompt but the extensions will most likely be updated properly. If that doesn't work, please create a support ticket.
profile picture

sourkraut

#3
Finally got a round tuit.
Restarted WL as admin. Used the restart button in Extension manager.

I'm curious, do the eleveated rights applay to the restart as well?

It worked, as advertised. I did see an error message (IPC port: access denied) but the updates show as installed.

Thanks,

Eb

PS: after writing the above, and returning to WL I discovered, that the procedure:

QUOTE:
2. Instead, close it (WL) normally.
3. Now start WL with admin privileges explicitly by right-clicking its shortcut and selecting 'Run as admin'.


started a WL instance in the administrator folders (and configuration), rather than the instance I had used before.

The symptom was, that my special data sets had disappeared!

Restarting as regular user restored my data sets (whew!).
profile picture

Eugene

#4
QUOTE:
The symptom was, that my special data sets had disappeared!

Don't worry, that's expected because every Windows user has their own user data folder. You basically start from scratch. But the main folder under Program Files becomes fully accessible for installing extensions. Just for this step we need elevated privileges - as a workaround.
profile picture

sedelstein

#5
I've been trying to load updates with no success. I run WL as administrator, the Extension manager tells me I've succeeded and when WL reopens, they are not updated.

I had no problem on another pc

I run as administrator, use the extension manager to install. Tells me I've suceeded. Shutdown WL normally, Reopen as admin again.

Thoughts?
profile picture

Eugene

#6
profile picture

sedelstein

#7
I don't think I have both versions installed. How do I check and can one be safely removed?

Perhaps you meant this instead
QUOTE:
note: some Extensions can be incompatible with x64 version)
profile picture

Eugene

#8
QUOTE:
Perhaps you meant this instead

No, I meant that you have both x64 and x86 versions installed.

QUOTE:
How do I check and can one be safely removed?

As usual, in Windows Control Panel > Programs.

QUOTE:
they are not updated.

How did you determine that? Next, why you're upgrading them?

1. Heat Map is preinstalled and has never been updated.
2. Where on earth the WL4Files extension is coming from? It's not listed on our website.

These extensions require neither installation nor upgrade. I'm puzzled.
profile picture

sedelstein

#9
The only version I have is 64bit.
The other add-ins, extensions just showed up in the extension manager and I thought I should upgrade
profile picture

Eugene

#10
OK, then it's not an issue.