Error "Object reference not set... Unable to get Data on Demand for symbol..."
Author: jony
Creation Date: 11/21/2016 6:49 AM
profile picture

jony

#1
Hello,

I see from other posts that this is a somewhat nondescript error, and I can't find anything specifically applies to my problem.

Using: Wealth-Lab Pro 6.9

Problem: I have a number of very basic charting Strategies that I built some time ago (over a year), they've worked fine until recently when a few of them have started failing. The strategy will not display, instead it throws up an error message.

Error Message: "Object reference not set to an instance of an object. Unable to get Data on Demand for symbol: FCG."

I thought something might be wrong with the Strategy so I tried to just launch a new chart window and that fails too for the same error. So the problem appears to be related to these certain symbols, e.g. FCG, TVIX. I tried "Update Dataset Pricing" in the Data Manager and that says that it downloaded the data for these symbols just like all the others, but still I would have to suspect there's something wrong in the data. How do I track down what's gone wrong here?

Thanks,
John
profile picture

Eugene

#2
Hi John,

Whenever you have an issue please review the Wiki Knowledge Base for an instant solution. In particular, this looks like another incarnation of a known bug with Fidelity reverse splits:

Open Issues > Fidelity data can not be updated except for N minute

FCG and TVIX had reverse splits earlier this year. Please review the KB article for several workarounds to the problem.

Despite the reverse split, at the same time the issue may be of a different kind i.e. corrupt chart drawing object in one or more bar intervals (less likely). So if the workarounds above won't help, here's a different troubleshooting technique:

Errors | Other > (scroll down to) Error message on a chart and/or copying chart to clipboard
profile picture

Eugene

#3
Update:

When the error message reads "...Unable to get Data on Demand for symbol..." as in this thread, it may also make sense to uncheck "Update Data on Demand" in the Data Manager.