ERROR IN VISUALIZERS AFTER UPGRADING TO 6.3
Author: Eugene
Creation Date: 2/28/2012 6:35 AM
profile picture

Eugene

#1
Problem: you upgraded to 6.3 from any previous version. An "error in visualizer" pops up everytime you try to open a Strategy. This problem did not happen before.



Solution: upgrade the visualizer library extension(s) to the most-recent build, restart WLP/WLD and this error message will disappear.


Further reading:

1. Our Home Page saying "Upgrade Performance Visualizer Extensions for 6.3 Compatibility"

2. Wealth-Lab's Home Page Tool and a note in the User Guide

3. The top entry of these two change logs of the visualizer libraries: HERE and HERE

4. Finally, these dedicated forum threads with explicit instructions:

* MS123 Performance Visualizers (last post)
* Analysis Series + Monte Carlo (last post)
* Note to visualizer developers.

Hope that helps.
profile picture

ell7123

#2
Installed most recent visualizers. Same problem - but now limited only to "Analysis Series"
profile picture

ell7123

#3
Okay - never mind. I didn't realize a portion of the extensions were not installed when doing it from Extension Manager.
profile picture

Eugene

#4
Restart WLP.
profile picture

stevenxie66

#5
I got a similar error (see attachment). I have Fidelity Wealth-Lab 6.4 (64-bit) Edition on Windows 8 Pro. The Wealth Lab HeatMap 1.0.0.0, Performance Visualizer library 2013.01 and Extra Performance Visualizers 2012.03 were installed.

profile picture

Eugene

#6
I think the only reason why this might be happening in 6.4 is that you reinstalled the Heat Map extension from the website, overwriting the already canned (built in) file. It hasn't ever been recompiled for 6.3, and installation of this extension reverted its state to the pre-6.3 times.

Remove the WealthLab.Visualizers.Extensions.dll file from "c:\Program Files\Fidelity Investments\Wealth-Lab Pro 6\" and use Windows Control Panel to Repair your WLP installation. This should restore the built-in file recompiled for 6.3+ and .NET4.

UPDATE 07/19/2017: Since WL6 ships with Heat Map the old build has become problematic. We've taken down the incompatible Heat Map build.
profile picture

123blee9

#7
That seemed to have worked, BUT now the strategies I trade do not load into WLP. I received the error message that none of those strategies reloaded when I opened WLP after following your instructions. The strategies in other directories seem all fine. 'blee_Trade' shows no stratagies, and when I attempt to import the xml files, I receive the attached error message.

Major help needed getting these back!

Thanks.
profile picture

Eugene

#8
My instructions do not concern your strategies because they aren't affected by WLP/D installation repair. Please start a new support ticket or forum thread.

Also, kindly respond to my question in your open ticket. Thanks.