Different Results from Same Strategy
Author: rmpwealth
Creation Date: 2/14/2013 11:37 AM
profile picture

rmpwealth

#1
I run W-L on two different computers (desktop @ home; laptop on road). When running the same strategy on both, I get slightly different results. Specifically, the trade dates and prices are the same on each, but the Profit %, Profit $, etc. are slightly different -- very close, but not exactly the same. As far as I can tell, all settings are the same on both computers. At first I suspected that each computer was drawing from a different historical database, but as I said, the trade dates and prices show the same on both computers (however, while I am posting -- how do I determine which historical database the strategy is using?). The problem seems to be in the calculation of the Profit % and Profit $. Or possibly the trades are differing in decimal quantities that are not visible on the Trade Screen (i.e. -- the Quantity column shows whole numbers; perhaps one computer or the other is trading fractional shares?). The only other difference is that the desktop is running Windows XP, and the laptop is running Windows 7 Pro (64-bit). Any thoughts why the results wouldn't be exactly the same on both computers?
profile picture

Eugene

#2
Either your data files are different, or some setting. To make a correct comparison, the WLP settings and the data on both of your PCs must be in sync. The easiest way to do it is by sharing the same physical data files (not "updated at approximately the same time"), retaining WLP build number, and copying all the configuration files by mirroring the Wealth-Lab's Data folder (under AppData\Roaming) with all its contents. This way, one can ensure that every possible preference was preserved. Hope that helps, and in the end it's all up to you because the PCs are in your hands.
profile picture

Cone

#3
A slight difference in trade prices could be caused by limit/stop order rounding used on one computer, but not the other. Eugene's solution would take care of it, but check Preferences (F12) > Backtest Settings > Turn off limit/stop order rounding entirely (last option)