Community.Components namespace cannot be found
Author: Ninozah
Creation Date: 4/25/2013 6:38 PM
profile picture

Ninozah

#1
I downloaded:
Community Components library by MS123 (Eugene)
Category: Addin
Version: 2012.12.3
Licence: Freeware

It is a file of about 3k. I renamed it to: "Community.Components.wle" and stored it in Wealth lab directory:
C:\Program Files\Fidelity Investments\Wealth-Lab Pro 6\

When I run the code I still get error message, line 7: namespace "Community" could not be found.

Here is the sample code that generates the error message:

CODE:
Please log in to see this code.
profile picture

Eugene

#2
Just select "Open file" in your browser next time - not "Save" as you did. WLP is already set to install an extension so usually, nobody has to deal with those WLE files directly. For more details please see this illustrated tutorial:

How do I install Wealth-Lab extensions?

By the way, a WLE is a bootstrapper file - sort of Windows shortcut to an executable. Placing it anywhere will have zero effect.
profile picture

Ninozah

#3
Thank you so much Eugene! It worked! I do not get an error message. But I used one of the codes from the example of Pattern Recognition. It compiles but does not generate any results. Am I missing something else?

http://www2.wealth-lab.com/WL5WIKI/PatternRecognition.ashx
profile picture

Eugene

#4
Load more than 200 bars of data, and run it on a sufficient number of symbols. M Top/M Bottom patterns don't emerge every day.
profile picture

Ninozah

#5
I also thought so, but I ran on 250 bars and the whole set nasdaq100 and dow30. Nothing. Although visually I saw quute a few. Any other suggestion please?
profile picture

Eugene

#6
Switch to Raw Profit mode and load even more data.