Can WL4 Files Provider still access WL4 DataSource?
Author: KGo
Creation Date: 9/29/2017 4:20 PM
profile picture

KGo

#1
I wish to access old wlp4 wl4 files using the wlp6 wl4 data provider. The option to select a wl4 DataSource is grayed out. Any way to turn that on so the ABC... folder structure is recognized? Maybe move the files to a particular location?

How do you recommend structuring data for the provider if DataSource structure is not accessable? There are 5,000+ symbols
profile picture

Eugene

#2
Select the Pro option - Developer is N/A in your case. This way it should read whatever it can.
profile picture

KGo

#3
Pro Option reads the contents of a single folder and no sub folders. :-(

I found (User Guide> Data > Data Manager > Create New DataSet > Data Providers >WL4 Files) that the wl4 DataSource option is disabled if WL4 is not on same machine or if operating WL6 in 64 bit mode. Seems by design I cannot access a DataSource.

So I guess we must copy all files into a single folder or create 26 datasources. Any other ideas?
profile picture

Eugene

#4
Yes, this is by design.

What kind of data is this that you've been keeping for so long?
profile picture

KGo

#5
It's mostly Stock, and ETF Data. It provides delisted symbol data for testing with limited survivorship bias.
profile picture

Eugene

#6
Makes sense. How about installing 32-bit Wealth-Lab Pro side by side? This should unlock the DataSource option.

P.S. For extensive delisted symbol data you might want to check NorgateData aka PremiumData.
profile picture

KGo

#7
Thanks for Norgate.

Installed 32 bit WLP which did enable the DataSource option. However, it gives an error "Database connection failed. Check validity of the Database path." That error occurs accessing WL4 machine on the network or data files stored on the WL6 machine. WL4 is on a separate machine so that is likely the cause unless you have another suggestion.

Meanwhile I implemented a single folder for an all WL4 files datasource on WLP 64bit version. Microsoft Robocopy was used to copy all WL files to a single folder as suggested https://stackoverflow.com/questions/8690245/robocopy-copy-folders-content-to-a-single-folder . Then set it as a scheduled task to stay updated.
profile picture

Eugene

#8
Sorry, can't help you out with this. We don't support anything WL4 and I haven't had any legacy *.WL files for many years (let alone WLP4.x).
profile picture

KGo

#9
No problem Eugene. It's working with all WL4 files in the single folder.