Broker Adapter
Author: ChrisM
Creation Date: 8/29/2008 6:16 AM
profile picture

ChrisM

#1
I would like to create a broker adapter to IB as an extension of WealthLab Developer 5.1. Where can I find the documentation of the extension manager API?
profile picture

Eugene

#2
1. Fidelity is reviewing their API documentation therefore it all was removed for some time.
2. Currently no broker API is available in Developer - this is a Fidelity decision.
profile picture

ChrisM

#3
Then, honestly, I don't understand, why to use WealthLab Developer 5.
The advantage of the new .net architecture that would allow writing own extensions seems to be unusable.
For backtesting purposes one could continue using Wealthlab Developer 3 or 4. In Version 5 there is not more but less backtesting functionality, e.g.: SimuScripts, Portfolio tool.
For automated trading one can only recomend competitive products like RightEdge or OpenQuant, as long as the policy stays as restricitve as it is.
It's too bad about this nice product!

Regards,
Chris
profile picture

Eugene

#4
Edit (link fixed)

QUOTE:
In Version 5 there is not more but less backtesting functionality, e.g.: SimuScripts, Portfolio Tool.

PosSizers - the new name for Simuscripts - are simply not implemented yet. I'm bored to repeat this sentence once again today, but the remaining and additional functionality will be released in phases. It is just the initial release of a new product.
QUOTE:
The advantage of the new .net architecture that would allow writing own extensions seems to be unusable.

WL5 is even more extensible, let alone user friendly. Static and streaming providers (sadly, no fundamental providers except for those that already exist), user libraries for commissions, strategy packs, indicator groups, performance visualizers to name a few. Have you already seen our Wiki for an open source example of extending the backtesting functionality?
Not to mention that WL5 is several times faster.

We should have a product comparison page in a short while.
profile picture

Jan van der Wel

#5
Dear All,

I hope that Fidelity allows you to introduces an Open Broker API or IB integration, otherwise it makes Wealt-lab .NET worthless for automated trading in Europe where IB offers their platform via various brokers. Please keep your software open! Your added value should be helping by offering real added value by great functionality as I've experienced until now, not by forcing the users into a closed harness. Otherwise a competitor will provide the functionality such as Amibroker which provides the particular functionality.

Regards,
Jan van der Wel

profile picture

hylt

#6
Bad news.
profile picture

odeedo

#7
Nothing changed?

These are very bad news.

With other words, you are selling Wealth-Lab Developer 5.1 to non US residents,
but first you do not build in all the data provider you supported in Wealth Lab 4 especially the non US Data Provider.
Secondly you hide your API, so it is not possible to write an own extension.

We call this protectionism!

Looking for other sw or better news.

Regards
odeedo




profile picture

kfmfe04

#8
Not being able to hook up IB is a deal-breaker.

Anyone have any suggestions for workable alternatives to Wealth-Lab.Net (besides WL 4)?
Thanks.
profile picture

DrKoch

#9
I use RightEdge.
profile picture

RA81

#10
Want to make data provider for my broker in Russia but, have no api. All files are obsfurcated and i havnt time for decompiling it.

can use this programm only for backtesting. its not good.

GIVE us DOCS!!!
profile picture

Eugene

#11
It's good that you can still use this program despite that your trial has expired, isn't it? ;)
profile picture

RA81

#12
QUOTE:
It's good that you can still use this program despite that your trial has expired, isn't it? ;)


yes , its good. just reinstall it. I cant use it fully because of many restrictions. I cant trade, cant analise my data, cant write my modules. I Try to make WLD usable for me. If i will ok with this, it will be a reason for pay. At this time WLD is veary unfinished (but great potential ). I cant use Fideliti servers for trading, i need my broker adapter, data adapter, comission module e.t.c.

i hope you understand me
profile picture

Eugene

#13
QUOTE:
just reinstall it.

This is a lie.
profile picture

RA81

#14
QUOTE:
This is a lie.

write your mail to me [edited] and i will show you than i dont lie. I Dont want talk about it here.
profile picture

Eugene

#15
All right, for a private talk you could create a support ticket. By the way, I'd like to tell you one thing about the latest update of your ChartStyle library.