Beta indicator: how to change symbol?
Author: wmrgrove
Creation Date: 8/15/2012 12:42 PM
profile picture

wmrgrove

#1
I have loaded the "Community Indicators" and want to use the Beta indicator. When I load it on a chart the info says ;

"This indicator calculates the Beta of a security to a specific market over a specified period.For example, enter ^GSPC for the Yahoo! symbol for S&P 500 Index."

I would like to use "spy" or other tickers for my ref but there is no field to enter symbol when I apply the indicator.
In the Beta properities menu there is an index field but you can't enter a ticker???

Thanks for any help, Bill

profile picture

Eugene

#2
You can not change a different symbol in the Indicator Properties dialog. This is only possible in Strategy code. This is a known limitation not subject to change for architectural reasons (basically, only numeric parameters are supported in the dialog and for Strategy Parameters for the same matter).
profile picture

wmrgrove

#3
Ok, I understand limitations.

So I cut and pasted a "spy Beta" coded strategy and it works.
Now, can I save the strategy as a my own custom indicator?

Thanks, Bill
profile picture

Cone

#4
You can't save it as an integrated custom indicator, but you can:

1. Save the Strategy as a starting point for a new strategy. After opening the code and making edits, make sure to click "Save As" when saving the new strategy.

2. Click Edit > Save as Default Template Code. Then, any time you start with a new Strategy from Code, that template will be there immediately.
profile picture

wmrgrove

#5
Got it!! Thanks for the help!
profile picture

wmrgrove

#6
One more question?

I am a Fidelity customer and use that data update. They do not recognize the symbol ^GSPC used in the Community Beta indicator, so I selected update data for symbol ^GSPC from Yahoo on the data mgr and it would not update the symbol. Am I doing something wrong here???

Thanks, Bill
profile picture

Eugene

#7
Just double checked and ^GSPC will update perfectly up to 08/22/2012. Could be a temporary server issue, or you were updating too soon after the close (let Yahoo at least a few hours, or activate "Always return data with partial bar" in Data Manager > Yahoo tab.)
profile picture

wmrgrove

#8
works fine now, thanks