Alerts, Autostage and Autotrade
Author: topcat77
Creation Date: 9/2/2008 7:12 PM
profile picture

topcat77

#1
I have eight strategies that run on 1-minute bars. If I Autostage them all I can see all the alerts in the order box, no problem. I now Autotrade only two of them, so I Autostage and Autotrade those; also works fine. The problem is that I can't see the alerts on the other six. I've tried the "show all alerts" tab but that simply gives me results for my end-of-day strategies.Two questions:
1) is there a way that WL allows all strategies to be Autostaged and only some to go on to Autotrade?
2) or else how can I see alerts on the strategies that are not staged or sent to Autotrade?
profile picture

Cone

#2
1. Not really. When you enable "Auto-Trading", the option Auto-Stage becomes Auto-Place to indicate that these trades will be placed immediately. It all has to do with the mode of the Orders tool - it's either a place that holds staged orders until you place them, or it's placing them immediately (Auto-Trading).

The option for you would be to turn on Auto-Place for your completely automated strategies, and leave it off for the others. For those, you can select and "Place Selected orders" right from the Alerts pane.

2. It seems to me that you're looking for Alerts for Strategies that don't have any. Note that Strategies showing Alerts have a red /!\ icon to the left of the Strategy in the upper pane, and, the number of Alerts is indicated in the "Alerts" column. If Alerts is 0 and the icon doesn't appear, the Strategy does not currently have alerts.
profile picture

topcat77

#3
1)Thanks

On 2) the reason I scramble around looking for an alert is because the system has broadcast an audio signal.